 <!DOCTYPE html>
<!--[if IE 8]>
	<html class="ie ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>
	<html class="ie ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!-->
<html lang="en-US"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://nehandatv.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa - Nehanda TV</title>
<link rel="canonical" href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa - Nehanda TV" />
<meta property="og:description" content="Seventh Day Adventist church Elder, Albert Machando with a sermon delivered on the 17th of December titled &quot;Huchenjeri Vakapusa&quot; where he says &quot;we only want good when it suits us.&quot; In September 2020 Machando made headlines after imploring men in relationships to provide for their girlfriends financially." />
<meta property="og:url" content="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/" />
<meta property="og:site_name" content="Nehanda TV" />
<meta property="article:publisher" content="https://www.facebook.com/NehandaTV" />
<meta property="article:published_time" content="2022-12-20T15:18:30+00:00" />
<meta property="og:image" content="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Nehanda TV" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@nehandatv" />
<meta name="twitter:site" content="@nehandatv" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Nehanda TV" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/","url":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/","name":"SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa - Nehanda TV","isPartOf":{"@id":"https://nehandatv.com/#website"},"primaryImageOfPage":{"@id":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#primaryimage"},"image":{"@id":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#primaryimage"},"thumbnailUrl":"https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg","datePublished":"2022-12-20T15:18:30+00:00","dateModified":"2022-12-20T15:18:30+00:00","author":{"@id":"https://nehandatv.com/#/schema/person/fc3eb921552e872f0ccacc5765e58997"},"breadcrumb":{"@id":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#primaryimage","url":"https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg","contentUrl":"https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg","width":1280,"height":720},{"@type":"BreadcrumbList","@id":"https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://nehandatv.com/"},{"@type":"ListItem","position":2,"name":"Videos","item":"https://nehandatv.com/videos/"},{"@type":"ListItem","position":3,"name":"SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa"}]},{"@type":"WebSite","@id":"https://nehandatv.com/#website","url":"https://nehandatv.com/","name":"Nehanda TV","description":"Videos for Zimbabwe by Zimbabweans","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://nehandatv.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://nehandatv.com/#/schema/person/fc3eb921552e872f0ccacc5765e58997","name":"Nehanda TV","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nehandatv.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=96&d=mm&r=g","caption":"Nehanda TV"},"sameAs":["https://twitter.com/nehandatv"],"url":"https://nehandatv.com/author/kaguvi/"}]}</script>

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Feed" href="https://nehandatv.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Comments Feed" href="https://nehandatv.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa Comments Feed" href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nehandatv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://149516129.v2.pressablecdn.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://149516129.v2.pressablecdn.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='share-this-share-buttons-sticky-css' href='https://149516129.v2.pressablecdn.com/wp-content/plugins/sharethis-share-buttons/css/mu-style.css?ver=1670373554' type='text/css' media='all' />
<link rel='stylesheet' id='better-framework-main-fonts-css' href='https://fonts.googleapis.com/css?family=Lato:400,700%7CRoboto:400,500,700,400italic&#038;display=swap' type='text/css' media='all' />
<script type='text/javascript' id='cookie-law-info-js-extra'>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</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/cookie-law-info/lite/frontend/js/script.min.js?ver=3.0.7' id='cookie-law-info-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jquery-js-after'>
jQuery(document).ready(function() {
	jQuery(".946dfb7d95b85a3aac31246e44da1f35").click(function() {
		jQuery.post(
			"https://nehandatv.com/wp-admin/admin-ajax.php", {
				"action": "quick_adsense_onpost_ad_click",
				"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
				"quick_adsense_nonce": "e21ae88673",
			}, function(response) { }
		);
	});
});
</script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js?ver=2.1.6#property=59bef23fd022ae0011cd882a&#038;product=inline-wp-buttons&#038;source=sharethis-share-buttons-wordpress' id='share-this-share-buttons-mu-js'></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-49233918-3' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["nehandatv.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-49233918-3", {"anonymize_ip":true});
gtag("config", "G-KFQDQX0DNJ");
</script>

<!--[if lt IE 9]>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/themes/publisher/includes/libs/better-framework/assets/js/html5shiv.min.js?ver=3.15.0' id='bf-html5shiv-js'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/themes/publisher/includes/libs/better-framework/assets/js/respond.min.js?ver=3.15.0' id='bf-respond-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://nehandatv.com/wp-json/" /><link rel="alternate" type="application/json" href="https://nehandatv.com/wp-json/wp/v2/posts/60516" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nehandatv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nehandatv.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://nehandatv.com/?p=60516' />
<link rel="alternate" type="application/json+oembed" href="https://nehandatv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnehandatv.com%2F2022%2F12%2F20%2Fsda-church-mandara-elder-albert-machando-huchenjeri-vakapusa%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nehandatv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnehandatv.com%2F2022%2F12%2F20%2Fsda-church-mandara-elder-albert-machando-huchenjeri-vakapusa%2F&#038;format=xml" />
<link rel="amphtml" href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/amp/" />
<meta name="generator" content="Site Kit by Google 1.90.1" /><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});
_taboola.push({additional_data:{sdkd:{
    "os" : "Wordpress",
    "osv" : "6.1.1",
    "php_ver" : "8.2.0",
    "sdkt" : "Taboola Wordpress Plugin",
    "sdkv" : "1.0.15",
    "location" : ""
}}});
!function (e, f, u) {
	e.async = 1;
  e.src = u;
  f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/gandaco-nehandatv/loader.js');</script><script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=59bef23fd022ae0011cd882a&product=inline-share-buttons-wp"></script>
<meta name="google-site-verification" content="s5gP_JiEVy8xPHeYem8fJMNLKiyx542BXp6nsYpzqW0" />
<link rel="manifest" href="/manifest.json" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(function() {
    OneSignal.init({
      appId: "79c8c945-5a74-4e3e-a447-421f8b89a839",
    });
  });
</script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gandaco-nehandatv/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://nehandatv.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '79c8c945-5a74-4e3e-a447-421f8b89a839';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://nehandatv.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<script type="application/ld+json">{
    "@context": "http://schema.org/",
    "@type": "Organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/04/NehandaTVRetinalogo.png"
    },
    "url": "https://nehandatv.com/",
    "name": "Nehanda TV",
    "description": "Videos for Zimbabwe by Zimbabweans"
}</script>
<script type="application/ld+json">{
    "@context": "http://schema.org/",
    "@type": "WebSite",
    "name": "Nehanda TV",
    "alternateName": "Videos for Zimbabwe by Zimbabweans",
    "url": "https://nehandatv.com/"
}</script>
<script type="application/ld+json">{
    "@context": "http://schema.org/",
    "@type": "BlogPosting",
    "headline": "SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa",
    "description": "Seventh Day Adventist church Elder, Albert Machando with a sermon delivered on the 17th of December titled \"Huchenjeri Vakapusa\" where he says \"we only want good when it suits us.\" In September 2020 Machando made headlines after imploring men in relationships to provide for their girlfriends financially.",
    "datePublished": "2022-12-20",
    "dateModified": "2022-12-20",
    "author": {
        "@type": "Person",
        "@id": "#person-NehandaTV",
        "name": "Nehanda TV"
    },
    "image": "https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg",
    "interactionStatistic": [
        {
            "@type": "InteractionCounter",
            "interactionType": "http://schema.org/CommentAction",
            "userInteractionCount": "0"
        }
    ],
    "publisher": {
        "@id": "#organization"
    },
    "mainEntityOfPage": "https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/"
}</script>

<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9836702761589703&amp;host=ca-host-pub-2644536267352236" crossorigin="anonymous" type="text/javascript"></script>

<link rel='stylesheet' id='bf-minifed-css-1' href='https://149516129.v2.pressablecdn.com/wp-content/bs-booster-cache/e47df0562d34402a49d7b922f99e205a.css' type='text/css' media='all' />
<link rel='stylesheet' id='7.11.0-1671771142' href='https://149516129.v2.pressablecdn.com/wp-content/bs-booster-cache/1a6f40df3f8b942296e3f6ccfc68162b.css' type='text/css' media='all' />
<link rel="icon" href="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-270x270.jpg" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> </head>
<body class="post-template-default single single-post postid-60516 single-format-standard bs-theme bs-publisher bs-publisher-clean-magazine active-light-box active-top-line ltr close-rh page-layout-2-col page-layout-2-col-right full-width main-menu-sticky-smart main-menu-full-width active-ajax-search single-cat-7 single-cat-8158 single-prim-cat-14 single-cat-14  bs-hide-ha wpb-js-composer js-comp-ver-6.7.0 vc_responsive bs-ll-a" dir="ltr">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="off-canvas-overlay"></div>
<div class="off-canvas-container left skin-white">
<div class="off-canvas-inner">
<span class="canvas-close"><i></i></span>
<div class="off-canvas-header">
<div class="site-description">Videos for Zimbabwe by Zimbabweans</div>
</div>
<div class="off-canvas-search">
<form role="search" method="get" action="https://nehandatv.com">
<input type="text" name="s" value="" placeholder="Search...">
<i class="fa fa-search"></i>
</form>
</div>
<nav class="off-canvas-menu">
<ul class="menu bsm-pure clearfix">
<li id="menu-item-52787" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home better-anim-fade menu-item-52787"><a href="https://nehandatv.com/">Home</a></li>
<li id="menu-item-1555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-11 better-anim-fade menu-item-1555"><a href="https://nehandatv.com/category/news/">News</a></li>
<li id="menu-item-1552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-1552"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li id="menu-item-52786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-1807 better-anim-fade menu-item-52786"><a href="https://nehandatv.com/category/showbiz/">Showbiz</a></li>
<li id="menu-item-1556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-13 better-anim-fade menu-item-1556"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li id="menu-item-10924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-15 better-anim-fade menu-item-10924"><a href="https://nehandatv.com/category/sports/">Sports</a></li>
<li id="menu-item-1551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-1551"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
<li id="menu-item-1563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-5 better-anim-fade menu-item-1563"><a href="https://nehandatv.com/category/crime/">Crime &amp; Courts</a></li>
<li id="menu-item-1554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-10 better-anim-fade menu-item-1554"><a href="https://nehandatv.com/category/music/">Music</a></li>
<li id="menu-item-10925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-10925"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
<li id="menu-item-1557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-8 better-anim-fade menu-item-1557"><a href="https://nehandatv.com/category/interviews/">Interviews</a></li>
<li id="menu-item-52788" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-14 better-anim-fade menu-item-52788"><a href="https://nehandatv.com/category/religious/">Religious</a></li>
</ul>
</nav>
<div class="off_canvas_footer">
<div class="off_canvas_footer-info entry-content">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button colored in-4-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-title"> Likes </span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-title"> Subscribers </span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item rss"><a href="https://nehandatv.com/feed/rss/" target="_blank"> <i class="item-icon bsfi-rss"></i><span class="item-title"> Subscribe </span> </a> </li> </ul>
</div>
</div>
</div>
</div>
</div>
<div class="main-wrap content-main-wrap">
<header id="header" class="site-header header-style-2 full-width" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<section class="topbar topbar-style-1 hidden-xs hidden-xs">
<div class="content-wrap">
<div class="container">
<div class="topbar-inner clearfix">
<div class="section-links">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button not-colored in-4-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-title"> Likes </span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-title"> Subscribers </span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-title"> Followers </span> </a> </li> </ul>
</div>
<a class="topbar-sign-in behind-social" data-toggle="modal" data-target="#bsLoginModal">
<i class="fa fa-user-circle"></i> Sign in </a>
<div class="modal sign-in-modal fade" id="bsLoginModal" tabindex="-1" role="dialog" style="display: none">
<div class="modal-dialog" role="document">
<div class="modal-content">
<span class="close-modal" data-dismiss="modal" aria-label="Close"><i class="fa fa-close"></i></span>
<div class="modal-body">
<div id="form_82955_" class="bs-shortcode bs-login-shortcode ">
<div class="bs-login bs-type-login" style="display:none">
<div class="bs-login-panel bs-login-sign-panel bs-current-login-panel">
<form name="loginform" action="https://nehandatv.com/wp-login.php" method="post">
<div class="login-header">
<span class="login-icon fa fa-user-circle main-color"></span>
<p>Welcome, Login to your account.</p>
</div>
<div class="login-field login-username">
<input type="text" name="log" id="form_82955_user_login" class="input" value="" size="20" placeholder="Username or Email..." required />
</div>
<div class="login-field login-password">
<input type="password" name="pwd" id="form_82955_user_pass" class="input" value="" size="20" placeholder="Password..." required />
</div>
<div class="login-field">
<a href="https://nehandatv.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fnehandatv.com%2F2022%2F12%2F20%2Fsda-church-mandara-elder-albert-machando-huchenjeri-vakapusa%2F" class="go-reset-panel">Forget password?</a>
<span class="login-remember">
<input class="remember-checkbox" name="rememberme" type="checkbox" id="form_82955_rememberme" value="forever" />
<label class="remember-label">Remember me</label>
</span>
</div>
<div class="login-field login-submit">
<input type="submit" name="wp-submit" class="button-primary login-btn" value="Log In" />
<input type="hidden" name="redirect_to" value="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/" />
</div>
</form>
</div>
<div class="bs-login-panel bs-login-reset-panel">
<span class="go-login-panel"><i class="fa fa-angle-left"></i> Sign in</span>
<div class="bs-login-reset-panel-inner">
<div class="login-header">
<span class="login-icon fa fa-support"></span>
<p>Recover your password.</p>
<p>A password will be e-mailed to you.</p>
</div>
<form name="lostpasswordform" id="form_82955_lostpasswordform" action="https://nehandatv.com/wp-login.php?action=lostpassword" method="post">
<div class="login-field reset-username">
<input type="text" name="user_login" class="input" value="" placeholder="Username or Email..." required />
</div>
<div class="login-field reset-submit">
<input type="hidden" name="redirect_to" value="" />
<input type="submit" name="wp-submit" class="login-btn" value="Send My Password" />
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="section-menu">
<div id="menu-top" class="menu top-menu-wrapper" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<nav class="top-menu-container">
<ul id="top-navigation" class="top-menu menu clearfix bsm-pure">
<li id="topbar-date" class="menu-item menu-item-date">
<span class="topbar-date">Friday, December 23, 2022</span>
</li>
<li id="menu-item-12172" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-12172"><a href="https://nehandatv.com/about-us/">About Us</a></li>
<li id="menu-item-15822" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-15822"><a href="https://nehandatv.com/contact-us-2/">Contact us</a></li>
<li id="menu-item-7934" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-7934"><a href="https://nehandatv.com/advertising/">Advertising</a></li>
<li id="menu-item-38970" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-38970"><a href="https://nehandatv.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-22541" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22541"><a href="http://nehandaradio.com/">Nehanda Radio</a></li>
<li id="menu-item-22542" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22542"><a href="http://tellyafrica.com/">Telly Africa</a></li>
<li id="menu-item-58533" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58533"><a href="https://dailymast.com/">Daily Mast</a></li>
<li id="menu-item-58532" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58532"><a href="https://footyhawk.com/">Footy Hawk</a></li>
</ul>
</nav>
</div>
</div>
</div>
</div>
</div>
</section>
<div class="header-inner">
<div class="content-wrap">
<div class="container">
<div class="row">
<div class="row-height">
<div class="logo-col col-xs-4">
<div class="col-inside">
<div id="site-branding" class="site-branding">
<p id="site-title" class="logo h1 img-logo">
<a href="https://nehandatv.com/" itemprop="url" rel="home">
<img id="site-logo" src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/04/NehandaTVRetinalogo.png" alt="Publisher" data-bsrjs="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/04/NehandaTVRetinalogo.png" />
<span class="site-title">Publisher - Videos for Zimbabwe by Zimbabweans</span>
</a>
</p>
</div>
</div>
</div>
<div class="sidebar-col col-xs-8">
<div class="col-inside">
<aside id="sidebar" class="sidebar" role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div class="ygmvehcxnk ygmvehcxnk-pubadban ygmvehcxnk-show-desktop ygmvehcxnk-show-tablet-portrait ygmvehcxnk-show-tablet-landscape ygmvehcxnk-show-phone ygmvehcxnk-loc-header_aside_logo ygmvehcxnk-align-center ygmvehcxnk-column-1 ygmvehcxnk-clearfix no-bg-box-model"><div id="ygmvehcxnk-53404-789907841" class="ygmvehcxnk-container ygmvehcxnk-type-image " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="53404" data-type="image"><a itemprop="url" class="ygmvehcxnk-link" href="https://dailymast.com/" target="_blank"><img class="ygmvehcxnk-image" src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2020/05/TV-and-Showbiz.png" alt="Daily Mast Advert" /></a></div></div> </aside>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="menu-main" class="menu main-menu-wrapper show-search-item show-off-canvas menu-actions-btn-width-2" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="main-menu-inner">
<div class="content-wrap">
<div class="container">
<nav class="main-menu-container">
<ul id="main-navigation" class="main-menu menu bsm-pure clearfix">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home better-anim-fade menu-item-52787"><a href="https://nehandatv.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-11 better-anim-fade menu-item-1555"><a href="https://nehandatv.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-1552"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-1807 better-anim-fade menu-item-52786"><a href="https://nehandatv.com/category/showbiz/">Showbiz</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-13 better-anim-fade menu-item-1556"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-15 better-anim-fade menu-item-10924"><a href="https://nehandatv.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-1551"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-5 better-anim-fade menu-item-1563"><a href="https://nehandatv.com/category/crime/">Crime &amp; Courts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-10 better-anim-fade menu-item-1554"><a href="https://nehandatv.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-10925"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-8 better-anim-fade menu-item-1557"><a href="https://nehandatv.com/category/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-14 better-anim-fade menu-item-52788"><a href="https://nehandatv.com/category/religious/">Religious</a></li>
</ul>
<div class="menu-action-buttons width-2">
<div class="off-canvas-menu-icon-container off-icon-left">
<div class="off-canvas-menu-icon">
<div class="off-canvas-menu-icon-el"></div>
</div>
</div>
<div class="search-container close">
<span class="search-handler"><i class="fa fa-search"></i></span>
<div class="search-box clearfix">
<form role="search" method="get" class="search-form clearfix" action="https://nehandatv.com">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" autocomplete="off">
<input type="submit" class="search-submit" value="Search">
</form>
</div>
</div>
</div>
</nav>
</div>
</div>
</div>
</div>
</header>
<div class="rh-header clearfix light deferred-block-exclude">
<div class="rh-container clearfix">
<div class="menu-container close">
<span class="menu-handler"><span class="lines"></span></span>
</div>
<div class="logo-container rh-img-logo">
<a href="https://nehandatv.com/" itemprop="url" rel="home">
<img src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/NehandaTVlogo-300x45.png" alt="Nehanda TV" /> </a>
</div>
</div>
</div>
<div class="container adcontainer"><div class="ygmvehcxnk ygmvehcxnk-after-header ygmvehcxnk-pubadban ygmvehcxnk-show-desktop ygmvehcxnk-show-tablet-portrait ygmvehcxnk-show-tablet-landscape ygmvehcxnk-loc-header_after ygmvehcxnk-align-center ygmvehcxnk-column-1 ygmvehcxnk-hide-on-phone ygmvehcxnk-clearfix no-bg-box-model"><div id="ygmvehcxnk-27187-1388857398" class="ygmvehcxnk-container ygmvehcxnk-type-code  ygmvehcxnk-hide-on-phone" itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="27187" data-type="code"><div id="ygmvehcxnk-27187-1388857398-place"></div><script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('ygmvehcxnk-27187-1388857398');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('ygmvehcxnk-27187-1388857398-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('ygmvehcxnk-27187-1388857398-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('ygmvehcxnk-27187-1388857398-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}</script></div></div></div><div class="content-wrap">
<main id="content" class="content-container">
<div class="container layout-2-col layout-2-col-1 layout-right-sidebar post-template-10">
<div class="row main-section">
<div class="col-sm-8 content-column">
<div class="single-container">
<article id="post-60516" class="post-60516 post type-post status-publish format-standard has-post-thumbnail  category-featured category-local category-religious tag-albert-machando tag-elder-albert-machando tag-seventh-day-adventist single-post-content">
<div class="single-featured"></div>
<div class="post-header-inner">
<div class="post-header-title">
<div class="term-badges floated"><span class="term-badge term-14"><a href="https://nehandatv.com/category/religious/">Religious</a></span><span class="term-badge term-7"><a href="https://nehandatv.com/category/featured/">Featured</a></span><span class="term-badge term-8158"><a href="https://nehandatv.com/category/local/">Local</a></span></div> <h1 class="single-post-title">
<span class="post-title" itemprop="headline">SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa</span>
</h1>
<div class="post-meta single-post-meta">
<a href="https://nehandatv.com/author/kaguvi/" title="Browse Author Articles" class="post-author-a post-author-avatar">
<img alt='' data-src='https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=26&d=mm&r=g' class='avatar avatar-26 photo avatar-default' height='26' width='26' /><span class="post-author-name">By <b>Nehanda TV</b></span> </a>
<span class="time"><time class="post-published updated" datetime="2022-12-20T17:18:30+02:00">On <b>Dec 20, 2022</b></time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60516"><i class="bf-icon  bsfi-fire-4"></i> 15,585</span><a href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#disqus_thread" title="Leave a comment on: &ldquo;SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a></div>
</div>
</div>
<div class="entry-content clearfix single-post-content">
<div style="margin-top: 0px; margin-bottom: 0px;" class="sharethis-inline-share-buttons"></div><p><strong>Seventh Day Adventist church Elder, Albert Machando with a sermon delivered on the 17th of December titled &#8220;Huchenjeri Vakapusa&#8221; where he says &#8220;we only want good when it suits us.&#8221;</strong></p>
<p><iframe title="SDA Church Mandara || Elder M. Machando|| Huchenjeri Vakapusa || 17 December |2022 || Time 9am ||" width="1170" height="658" src="https://www.youtube.com/embed/3m9r5AiqJLE?wmode=transparent&amp;rel=0&amp;feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><div class="946dfb7d95b85a3aac31246e44da1f35" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9836702761589703" data-ad-slot="2408623768" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>In September 2020 Machando made headlines after imploring men in relationships to provide for their girlfriends financially.</p>
<p>Elder Machando said men pay ladies of the night to give them a service, something they can easily get from the their girlfriends, yet they refuse to provide for their women for something that’s given so freely.</p>
<p>He went on to say women are stupid and silly for staying in relationships which are not mutually beneficial, slaving for a man who doesn’t see it fit to provide for them.</p>
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({mode:'thumbnails-b', container:'taboola-below-article', placement:'below-article', target_type: 'mix'});</script><div class="ygmvehcxnk ygmvehcxnk-post-bottom ygmvehcxnk-float-center ygmvehcxnk-align-center ygmvehcxnk-column-1 ygmvehcxnk-clearfix no-bg-box-model"><div id="ygmvehcxnk-30798-465831314" class="ygmvehcxnk-container ygmvehcxnk-type-code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="30798" data-type="code"><div id="ygmvehcxnk-30798-465831314-place"></div><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('ygmvehcxnk-30798-465831314');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('ygmvehcxnk-30798-465831314-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('ygmvehcxnk-30798-465831314-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('ygmvehcxnk-30798-465831314-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width < 768 ) { document.getElementById('ygmvehcxnk-30798-465831314-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}</script></div></div> </div>
<div class="entry-terms post-tags clearfix ">
<span class="terms-label"><i class="fa fa-tags"></i></span>
<a href="https://nehandatv.com/tag/albert-machando/" rel="tag">Albert Machando</a><a href="https://nehandatv.com/tag/elder-albert-machando/" rel="tag">Elder Albert Machando</a><a href="https://nehandatv.com/tag/seventh-day-adventist/" rel="tag">Seventh Day Adventist</a> </div>
</article>
<section class="next-prev-post clearfix">
<div class="prev-post">
<p class="pre-title heading-typo"><i class="fa fa-arrow-left"></i> Prev Post </p>
<p class="title heading-typo"><a href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/" rel="prev">We are Better than CCC and ZANU PF &#8211; Robert Chapman from DUZ</a></p>
</div>
</section>
</div>
<section id="comments-template-60516" class="comments-template comment-respond">
<div class="section-heading sh-t1 sh-s1"><span class="h-text">Comments</span>
</div>
<div id="comments" class="better-comments-area better-disqus-comments-area">
<div id="disqus_thread" data-post-id="60516"></div>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus</a>.</noscript>
</div>
</section>
</div>
<div class="col-sm-4 sidebar-column sidebar-column-primary">
<aside id="sidebar-primary-sidebar" class="sidebar" role="complementary" aria-label="Primary Sidebar Sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div id="bs-thumbnail-listing-1-2" class=" h-ni w-t primary-sidebar-widget widget widget_bs-thumbnail-listing-1"><div class=" bs-listing bs-listing-listing-thumbnail-1 bs-listing-single-tab pagination-animate"> <p class="section-heading sh-t1 sh-s1 main-term-none">
<span class="h-text main-term-none main-link">
Recent Videos </span>
</p>
<div class="bs-pagination-wrapper main-term-none more_btn bs-slider-first-item">
<div class="listing listing-thumbnail listing-tb-1 clearfix columns-1">
<div class="post-60516 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-14">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/12\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE-86x64.jpg&quot;,&quot;210&quot;:&quot;sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE-210x136.jpg&quot;,&quot;1280&quot;:&quot;sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/" class="post-url post-title">
SDA Church Mandara || Elder Albert Machando || Huchenjeri&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-12-20T17:18:30+02:00">Dec 20, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60516"><i class="bf-icon  bsfi-fire-4"></i>15,585</span><a href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#disqus_thread" title="Leave a comment on: &ldquo;SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60512 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-7">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="We are Better than CCC and ZANU PF &#8211; Robert Chapman from DUZ" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/12\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg-86x64.jpg&quot;,&quot;210&quot;:&quot;we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg-210x136.jpg&quot;,&quot;1280&quot;:&quot;we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/" class="post-url post-title">
We are Better than CCC and ZANU PF &#8211; Robert Chapman&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-12-19T20:50:20+02:00">Dec 19, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60512"><i class="bf-icon  bsfi-fire-4"></i>34,700</span><a href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/#disqus_thread" title="Leave a comment on: &ldquo;We are Better than CCC and ZANU PF &#8211; Robert Chapman from DUZ&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60508 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="WATCH: Ghana MP labels opponent the ‘Harry Maguire of economics’" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics-OwLswJwyYqM-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/12\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics-OwLswJwyYqM-86x64.jpg&quot;,&quot;210&quot;:&quot;watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics-OwLswJwyYqM-210x136.jpg&quot;,&quot;480&quot;:&quot;watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics-OwLswJwyYqM.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/12/02/watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/12/02/watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics/" class="post-url post-title">
WATCH: Ghana MP labels opponent the ‘Harry Maguire of&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-12-02T14:35:14+02:00">Dec 2, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60508"><i class="bf-icon  bsfi-fire-4"></i>25,544</span><a href="https://nehandatv.com/2022/12/02/watch-ghana-mp-labels-opponent-the-harry-maguire-of-economics/#disqus_thread" title="Leave a comment on: &ldquo;WATCH: Ghana MP labels opponent the ‘Harry Maguire of economics’&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60505 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Love Shouldn&#8217;t Hurt Collabo Video ft Winky D, Freeman, Ammara Brown" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/11/love-shouldn-8217-t-hurt-collabo-video-ft-winky-d-freeman-ammara-brown-kj4LYdyp2t4-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/11\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;love-shouldn-8217-t-hurt-collabo-video-ft-winky-d-freeman-ammara-brown-kj4LYdyp2t4-86x64.jpg&quot;,&quot;210&quot;:&quot;love-shouldn-8217-t-hurt-collabo-video-ft-winky-d-freeman-ammara-brown-kj4LYdyp2t4-210x136.jpg&quot;,&quot;1280&quot;:&quot;love-shouldn-8217-t-hurt-collabo-video-ft-winky-d-freeman-ammara-brown-kj4LYdyp2t4.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/11/25/love-shouldnt-hurt-collabo-video-ft-winky-d-freeman-ammara-brown/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/11/25/love-shouldnt-hurt-collabo-video-ft-winky-d-freeman-ammara-brown/" class="post-url post-title">
Love Shouldn&#8217;t Hurt Collabo Video ft Winky D, Freeman,&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-11-25T22:08:25+02:00">Nov 25, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60505"><i class="bf-icon  bsfi-fire-4"></i>10,960</span><a href="https://nehandatv.com/2022/11/25/love-shouldnt-hurt-collabo-video-ft-winky-d-freeman-ammara-brown/#disqus_thread" title="Leave a comment on: &ldquo;Love Shouldn&#8217;t Hurt Collabo Video ft Winky D, Freeman, Ammara Brown&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
 </div>
</div >
<div class="post-60502 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a alt="Poptain in the video for the song &quot;Mari&quot;" title="Poptain- Mari (Official Music Video)" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/11/Poptain-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/11\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;Poptain-86x64.jpg&quot;,&quot;210&quot;:&quot;Poptain-210x136.jpg&quot;,&quot;1260&quot;:&quot;Poptain.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/11/25/poptain-mari-official-music-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/11/25/poptain-mari-official-music-video/" class="post-url post-title">
Poptain- Mari (Official Music Video) </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-11-25T21:58:39+02:00">Nov 25, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60502"><i class="bf-icon  bsfi-fire-4"></i>5,582</span><a href="https://nehandatv.com/2022/11/25/poptain-mari-official-music-video/#disqus_thread" title="Leave a comment on: &ldquo;Poptain- Mari (Official Music Video)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
</div>
</div><div class="bs-pagination bs-ajax-pagination more_btn main-term-none clearfix">
<script>var bs_ajax_paginate_1602160701 = '{"query":{"category":"","tag":"","taxonomy":"","post_ids":"","post_type":"","count":"5","order_by":"date","order":"DESC","time_filter":"","offset":"","style":"listing-thumbnail-1","cats-tags-condition":"and","cats-condition":"in","tags-condition":"in","featured_image":"0","ignore_sticky_posts":"1","author_ids":"","disable_duplicate":"0","ad-active":0,"paginate":"more_btn","pagination-show-label":"1","columns":1,"listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"0","share":"0","comment":"0","review":"1"}},"override-listing-settings":"0","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"bs_post_listing","view":"Publisher_Thumbnail_Listing_1_Shortcode","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"more_btn","pagination-show-label":"1","override-listing-settings":"0","listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"0","share":"0","comment":"0","review":"1"}},"columns":1,"ad-active":false,"_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"f7faa54","data":{"vars":{"post-ranking-offset":5}}}';</script> <a rel="next" class="btn-bs-pagination" data-id="1602160701" title="Load More Posts">
<span class="loading" style="display: none;">
<i class="fa fa-refresh fa-spin fa-fw"></i>
</span>
<span class="loading" style="display: none;">
Loading ... </span>
<span class="loaded txt">
Load More Posts </span>
<span class="loaded icon">
<i class="fa fa-angle-down" aria-hidden="true"></i>
</span>
<span class="no-more" style="display: none;">
No More Posts
</span>
</a>
</div></div></div><div id="better-social-counter-2" class=" h-ni w-t primary-sidebar-widget widget widget_better-social-counter"><div class="section-heading sh-t1 sh-s1"><span class="h-text">Follow us for updates</span></div> <div class="  better-studio-shortcode bsc-clearfix better-social-counter style-box colored in-2-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" class="item-link" target="_blank"><i class="item-icon bsfi-facebook"></i> <span class="item-count"> Facebook</span> <span class="item-title"> Likes</span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" class="item-link" target="_blank"><i class="item-icon bsfi-twitter"></i> <span class="item-count"> 5,551</span> <span class="item-title"> Followers</span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" class="item-link" target="_blank"><i class="item-icon bsfi-youtube"></i> <span class="item-count"> Youtube</span> <span class="item-title"> Subscribers</span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" class="item-link" target="_blank"><i class="item-icon bsfi-instagram"></i> <span class="item-count"> Instagram</span> <span class="item-title"> Followers</span> </a> </li> </ul>
</div>
</div><div id="bs-thumbnail-listing-1-3" class=" h-ni w-t primary-sidebar-widget widget widget_bs-thumbnail-listing-1"><div class=" bs-listing bs-listing-listing-thumbnail-1 bs-listing-single-tab pagination-animate"> <p class="section-heading sh-t1 sh-s1 main-term-none">
<span class="h-text main-term-none main-link">
Most Commented this Week </span>
</p>
<div class="bs-pagination-wrapper main-term-none more_btn bs-slider-first-item">
<div class="listing listing-thumbnail listing-tb-1 clearfix columns-1">
<div class="post-60512 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-7">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="We are Better than CCC and ZANU PF &#8211; Robert Chapman from DUZ" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/12\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg-86x64.jpg&quot;,&quot;210&quot;:&quot;we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg-210x136.jpg&quot;,&quot;1280&quot;:&quot;we-are-better-than-ccc-and-zanu-pf-8211-robert-chapman-from-duz-J2JuC1fA7Pg.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/" class="post-url post-title">
We are Better than CCC and ZANU PF &#8211; Robert Chapman&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-12-19T20:50:20+02:00">Dec 19, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60512"><i class="bf-icon  bsfi-fire-4"></i>34,700</span><a href="https://nehandatv.com/2022/12/19/we-are-better-than-ccc-and-zanu-pf-robert-chapman-from-duz/#disqus_thread" title="Leave a comment on: &ldquo;We are Better than CCC and ZANU PF &#8211; Robert Chapman from DUZ&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60516 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-14">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa" data-src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/12/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2022\/12\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE-86x64.jpg&quot;,&quot;210&quot;:&quot;sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE-210x136.jpg&quot;,&quot;1280&quot;:&quot;sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa-3m9r5AiqJLE.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/" class="post-url post-title">
SDA Church Mandara || Elder Albert Machando || Huchenjeri&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-12-20T17:18:30+02:00">Dec 20, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60516"><i class="bf-icon  bsfi-fire-4"></i>15,585</span><a href="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/#disqus_thread" title="Leave a comment on: &ldquo;SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
</div>
</div></div></div><div id="bs-subscribe-newsletter-2" class=" h-ni w-t primary-sidebar-widget widget widget_bs-subscribe-newsletter"><div class="section-heading sh-t1 sh-s1"><span class="h-text">Sign up to get VIDEO alerts</span></div> <div class="bs-shortcode bs-subscribe-newsletter bs-feedburner-newsletter ">
<div class="subscribe-image">
<img src="https://149516129.v2.pressablecdn.com/wp-content/themes/publisher/images/other/email-illustration.png" alt="Sign up to get VIDEO alerts">
</div>
<div class="subscribe-message">
<p>Sign up to get VIDEO alerts</p>
</div>
<form method="post" action="//feedburner.google.com/fb/a/mailverify" class="bs-subscribe-feedburner clearfix" target="_blank">
<input type="hidden" value="nehandatv" name="uri" />
<input type="hidden" name="loc" value="en_US" />
<input type="text" id="feedburner-email" name="email" class="newsletter-email" placeholder="Enter your e-mail .." />
<button class="newsletter-subscribe" name="submit" type="submit">Subscribe</button>
</form>
</div>
</div></aside>
</div>
</div>
</div>
</main>
</div>
<footer id="site-footer" class="site-footer full-width">
<div class="footer-social-icons">
<div class="content-wrap">
<div class="container">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-big-button colored in-5-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"> <a href="https://www.facebook.com/NehandaTV" class="item-link" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-name"> Facebook</span> <span class="item-title-join"> Join us on Facebook</span> </a> </li> <li class="social-item twitter"> <a href="https://twitter.com/nehandatv" class="item-link" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-name"> Twitter</span> <span class="item-title-join"> Join us on Twitter</span> </a> </li> <li class="social-item youtube"> <a href="https://youtube.com/user/NehandaTV" class="item-link" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-name"> Youtube</span> <span class="item-title-join"> Join us on Youtube</span> </a> </li> <li class="social-item instagram"> <a href="https://instagram.com/nehandatv" class="item-link" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-name"> Instagram</span> <span class="item-title-join"> Join us on Instagram</span> </a> </li> </ul>
</div>
</div>
</div>
</div>
<div class="copy-footer">
<div class="content-wrap">
<div class="container">
<div class="row">
<div class="col-lg-12">
<div id="menu-footer" class="menu footer-menu-wrapper" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<nav class="footer-menu-container">
<ul id="footer-navigation" class="footer-menu menu clearfix">
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-12172"><a href="https://nehandatv.com/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-15822"><a href="https://nehandatv.com/contact-us-2/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-7934"><a href="https://nehandatv.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-38970"><a href="https://nehandatv.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22541"><a href="http://nehandaradio.com/">Nehanda Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22542"><a href="http://tellyafrica.com/">Telly Africa</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58533"><a href="https://dailymast.com/">Daily Mast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58532"><a href="https://footyhawk.com/">Footy Hawk</a></li>
</ul>
</nav>
</div>
</div>
</div>
<div class="row footer-copy-row">
<div class="copy-1 col-lg-6 col-md-6 col-sm-6 col-xs-12">
© 2022 - Nehanda TV. All Rights Reserved. </div>
<div class="copy-2 col-lg-6 col-md-6 col-sm-6 col-xs-12">
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
<span class="back-top"><i class="fa fa-arrow-up"></i></span>
<style id="cky-style-inline">[data-cky-tag]{visibility:hidden;}</style><script id="ckyBannerTemplate" type="text/template">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</script><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({flush: true});</script><script id='publisher-theme-pagination-js-extra'>
var bs_pagination_loc = {"loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>"};
</script>
<script id='publisher-js-extra'>
var publisher_theme_global_loc = {"page":{"boxed":"full-width"},"header":{"style":"style-2","boxed":"full-width"},"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>","translations":{"tabs_all":"All","tabs_more":"More","lightbox_expand":"Expand the image","lightbox_close":"Close"},"lightbox":{"not_classes":""},"main_menu":{"more_menu":"enable"},"top_menu":{"more_menu":"enable"},"skyscraper":{"sticky_gap":30,"sticky":true,"position":""},"share":{"more":false},"refresh_googletagads":"1","get_locale":"en-US","notification":{"subscribe_msg":"By clicking the subscribe button you will never miss the new articles!","subscribed_msg":"You're subscribed to notifications","subscribe_btn":"Subscribe","subscribed_btn":"Unsubscribe"}};
var publisher_theme_ajax_search_loc = {"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","previewMarkup":"<div class=\"ajax-search-results-wrapper ajax-search-no-product ajax-search-fullwidth\">\n\t<div class=\"ajax-search-results\">\n\t\t<div class=\"ajax-ajax-posts-list\">\n\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t<span>Posts<\/span>\n\t\t\t<\/div>\n\t\t\t<div class=\"posts-lists\" data-section-name=\"posts\"><\/div>\n\t\t<\/div>\n\t\t<div class=\"ajax-taxonomy-list\">\n\t\t\t<div class=\"ajax-categories-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Categories<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"categories\"><\/div>\n\t\t\t<\/div>\n\t\t\t<div class=\"ajax-tags-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Tags<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"tags\"><\/div>\n\t\t\t<\/div>\n\t\t<\/div>\n\t<\/div>\n<\/div>","full_width":"1"};
</script>
<div class="rh-cover noscroll gr-8 no-top-nav">
<span class="rh-close"></span>
<div class="rh-panel rh-pm">
<div class="rh-p-h">
<span class="user-login">
<span class="user-avatar user-avatar-icon"><i class="fa fa-user-circle"></i></span>
Sign in </span> </div>
<div class="rh-p-b">
<div class="rh-c-m clearfix"><ul id="resp-navigation" class="resp-menu menu clearfix"><li id="menu-item-57322" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-11 better-anim-fade menu-item-57322"><a href="https://nehandatv.com/category/news/">News</a></li>
<li id="menu-item-57314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-57314"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li id="menu-item-57315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-term-10 better-anim-fade menu-item-57315"><a href="https://nehandatv.com/category/music/">Music</a>
<ul class="sub-menu">
<li id="menu-item-57320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-57320"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
</ul>
</li>
<li id="menu-item-57316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-13 better-anim-fade menu-item-57316"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li id="menu-item-57317" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-14 better-anim-fade menu-item-57317"><a href="https://nehandatv.com/category/religious/">Religious</a></li>
<li id="menu-item-57318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-1807 better-anim-fade menu-item-57318"><a href="https://nehandatv.com/category/showbiz/">Showbiz</a></li>
<li id="menu-item-57319" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-term-8158 better-anim-fade menu-item-57319"><a href="https://nehandatv.com/category/local/">Local</a>
<ul class="sub-menu">
<li id="menu-item-57321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-57321"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
</ul>
</li>
</ul></div>
<form role="search" method="get" class="search-form" action="https://nehandatv.com">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" autocomplete="off">
<input type="submit" class="search-submit" value="">
</form>
</div>
</div>
<div class="rh-panel rh-p-u">
<div class="rh-p-h">
<span class="rh-back-menu"><i></i></span>
</div>
<div class="rh-p-b">
<div id="form_97777_" class="bs-shortcode bs-login-shortcode ">
<div class="bs-login bs-type-login" style="display:none">
<div class="bs-login-panel bs-login-sign-panel bs-current-login-panel">
<form name="loginform" action="https://nehandatv.com/wp-login.php" method="post">
<div class="login-header">
<span class="login-icon fa fa-user-circle main-color"></span>
<p>Welcome, Login to your account.</p>
</div>
<div class="login-field login-username">
<input type="text" name="log" id="form_97777_user_login" class="input" value="" size="20" placeholder="Username or Email..." required />
</div>
<div class="login-field login-password">
<input type="password" name="pwd" id="form_97777_user_pass" class="input" value="" size="20" placeholder="Password..." required />
</div>
<div class="login-field">
<a href="https://nehandatv.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fnehandatv.com%2F2022%2F12%2F20%2Fsda-church-mandara-elder-albert-machando-huchenjeri-vakapusa%2F" class="go-reset-panel">Forget password?</a>
<span class="login-remember">
<input class="remember-checkbox" name="rememberme" type="checkbox" id="form_97777_rememberme" value="forever" />
<label class="remember-label">Remember me</label>
</span>
</div>
<div class="login-field login-submit">
<input type="submit" name="wp-submit" class="button-primary login-btn" value="Log In" />
<input type="hidden" name="redirect_to" value="https://nehandatv.com/2022/12/20/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa/" />
</div>
</form>
</div>
<div class="bs-login-panel bs-login-reset-panel">
<span class="go-login-panel"><i class="fa fa-angle-left"></i> Sign in</span>
<div class="bs-login-reset-panel-inner">
<div class="login-header">
<span class="login-icon fa fa-support"></span>
<p>Recover your password.</p>
<p>A password will be e-mailed to you.</p>
</div>
<form name="lostpasswordform" id="form_97777_lostpasswordform" action="https://nehandatv.com/wp-login.php?action=lostpassword" method="post">
<div class="login-field reset-username">
<input type="text" name="user_login" class="input" value="" placeholder="Username or Email..." required />
 </div>
<div class="login-field reset-submit">
<input type="hidden" name="redirect_to" value="" />
<input type="submit" name="wp-submit" class="login-btn" value="Send My Password" />
</div>
</form>
</div>
</div>
</div>
</div> </div>
</div>
</div>
<script type='text/javascript' id='better-post-views-cache-js-extra'>
/* <![CDATA[ */
var better_post_views_vars = {"admin_ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","post_id":"60516"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/better-post-views/js/better-post-views.min.js?ver=1.6.0' id='better-post-views-cache-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"nehandatv"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"60516 https:\/\/nehandatv.com\/?p=60516","disqusShortname":"nehandatv","disqusTitle":"SDA Church Mandara || Elder Albert Machando || Huchenjeri Vakapusa","disqusUrl":"https:\/\/nehandatv.com\/2022\/12\/20\/sda-church-mandara-elder-albert-machando-huchenjeri-vakapusa\/","postId":"60516"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-includes/js/comment-reply.min.js?ver=6.1.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=6.1.1' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/better-adsmanager/js/advertising.min.js?ver=1.21.0' id='better-advertising-js'></script>
<script type='text/javascript' async="async" src='https://149516129.v2.pressablecdn.com/wp-content/bs-booster-cache/5cca18bc8d1be673067f07e55600ac58.js?ver=6.1.1' id='bs-booster-js'></script>
<script type="text/javascript">
			(function() {
			var t   = document.createElement( 'script' );
			t.type  = 'text/javascript';
			t.async = true;
			t.id    = 'gauges-tracker';
			t.setAttribute( 'data-site-id', '5fc540f6a86b8824c70ba09c' );
			t.src = '//secure.gaug.es/track.js';
			var s = document.getElementsByTagName( 'script' )[0];
			s.parentNode.insertBefore( t, s );
			})();
		</script>
<script>
var ygmvehcxnk=function(t){"use strict";return{init:function(){0==ygmvehcxnk.ads_state()&&ygmvehcxnk.blocked_ads_fallback()},ads_state:function(){return void 0!==window.better_ads_adblock},blocked_ads_fallback:function(){var a=[];t(".ygmvehcxnk-container").each(function(){if("image"==t(this).data("type"))return 0;a.push({element_id:t(this).attr("id"),ad_id:t(this).data("adid")})}),a.length<1||jQuery.ajax({url:'https://nehandatv.com/wp-admin/admin-ajax.php',type:"POST",data:{action:"better_ads_manager_blocked_fallback",ads:a},success:function(a){var e=JSON.parse(a);t.each(e.ads,function(a,e){t("#"+e.element_id).html(e.code)})}})}}}(jQuery);jQuery(document).ready(function(){ygmvehcxnk.init()});

</script>

<script>
 var disqus_shortname = 'nehandatv';
            (function () {
                var s = document.createElement('script'); s.async = true;
                s.type = 'text/javascript';
                s.src = '//' + disqus_shortname + '.disqus.com/count.js';
                (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
            }());
		//<script>

		(function(){
		var disqus_shortname = 'nehandatv';


		function beforeLoad(e,$wrapper, $this) {

             var $prevEl = jQuery('#disqus_thread');

             if($prevEl.length === 0) {
                 return;
             }

            $prevEl.removeAttr('id');

            $prevEl.addClass('disqus_thread_prev');
		}

		function appendDisqusScript(e,$wrapper, res) {

		if( typeof DISQUS === 'object' && DISQUS.reset ) {

        var info = res && res.info ? res.info : {};


		jQuery(".disqus_thread_prev").each(function(){

		    var $prevEl = jQuery(this),
		        $respond = $prevEl.closest('.comments-template'),
		     $link = $respond.parent().find('.ajaxified-comments-container');

            $link.show();
			$link.children().show();

			$respond.remove();

		});

		DISQUS.reset({
		reload: true,
		config: function () {
		this.page.identifier = info.post_id;
		this.page.url = info.permalink;
		this.page.title = info.title;
		}
		});



		} else {

		var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
		dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
		}

		};

		        appendDisqusScript();
		
		})();
		

</script>

</body>
</html>