<!DOCTYPE html>
<!--[if IE 8]>
	<html class="ie ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>
	<html class="ie ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!-->
<html lang="en-US"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://nehandatv.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Leonard Zhakata - Chero Kuchibva Cash (Official Music Video) - Nehanda TV</title>
<link rel="canonical" href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Leonard Zhakata - Chero Kuchibva Cash (Official Music Video) - Nehanda TV" />
<meta property="og:description" content="The evergreen Leonard Zhakata with his official video for the song &quot;Chero Kuchibva Cash.&quot;" />
<meta property="og:url" content="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/" />
<meta property="og:site_name" content="Nehanda TV" />
<meta property="article:publisher" content="https://www.facebook.com/NehandaTV" />
<meta property="article:published_time" content="2022-03-16T17:28:19+00:00" />
<meta property="og:image" content="https://149516129.v2.pressablecdn.com/wp-content/uploads/2022/03/leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@nehandatv" />
<meta name="twitter:site" content="@nehandatv" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Nehanda TV" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://nehandatv.com/#website","url":"https://nehandatv.com/","name":"Nehanda TV","description":"Videos for Zimbabwe by Zimbabweans","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://nehandatv.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg?fit=1280%2C720&ssl=1","contentUrl":"https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg?fit=1280%2C720&ssl=1","width":1280,"height":720},{"@type":"WebPage","@id":"https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#webpage","url":"https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/","name":"Leonard Zhakata - Chero Kuchibva Cash (Official Music Video) - Nehanda TV","isPartOf":{"@id":"https://nehandatv.com/#website"},"primaryImageOfPage":{"@id":"https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#primaryimage"},"datePublished":"2022-03-16T17:28:19+00:00","dateModified":"2022-03-16T17:28:19+00:00","author":{"@id":"https://nehandatv.com/#/schema/person/fc3eb921552e872f0ccacc5765e58997"},"breadcrumb":{"@id":"https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/"]}]},{"@type":"BreadcrumbList","@id":"https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://nehandatv.com/"},{"@type":"ListItem","position":2,"name":"Videos","item":"https://nehandatv.com/videos/"},{"@type":"ListItem","position":3,"name":"Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)"}]},{"@type":"Person","@id":"https://nehandatv.com/#/schema/person/fc3eb921552e872f0ccacc5765e58997","name":"Nehanda TV","image":{"@type":"ImageObject","@id":"https://nehandatv.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=96&d=mm&r=g","caption":"Nehanda TV"},"sameAs":["https://twitter.com/nehandatv"],"url":"https://nehandatv.com/author/kaguvi/"}]}</script>

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Feed" href="https://nehandatv.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Comments Feed" href="https://nehandatv.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video) Comments Feed" href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nehandatv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.9.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://c0.wp.com/c/5.9.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://c0.wp.com/c/5.9.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cookie-law-info-css' href='https://149516129.v2.pressablecdn.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css' href='https://149516129.v2.pressablecdn.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='share-this-share-buttons-sticky-css' href='https://149516129.v2.pressablecdn.com/wp-content/plugins/sharethis-share-buttons/css/mu-style.css?ver=1647538779' type='text/css' media='all' />
<link rel='stylesheet' id='better-framework-main-fonts-css' href='https://fonts.googleapis.com/css?family=Lato:400,700%7CRoboto:400,500,700,400italic&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://149516129.v2.pressablecdn.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.8-a.7' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.9.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jquery-js-after'>
jQuery(document).ready(function() {
	jQuery(".946dfb7d95b85a3aac31246e44da1f35").click(function() {
		jQuery.post(
			"https://nehandatv.com/wp-admin/admin-ajax.php", {
				"action": "quick_adsense_onpost_ad_click",
				"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
				"quick_adsense_nonce": "089d97a679",
			}, function(response) { }
		);
	});
});
</script>
<script type='text/javascript' id='cookie-law-info-js-extra'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"1","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":"","button_1_button_colour":"#61a229","button_1_button_hover":"#4e8221","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":"","button_2_hidebar":"","button_3_button_colour":"#dedfe0","button_3_button_hover":"#b2b2b3","button_3_link_colour":"#333333","button_3_as_button":"1","button_3_new_win":"","button_4_button_colour":"#dedfe0","button_4_button_hover":"#b2b2b3","button_4_link_colour":"#333333","button_4_as_button":"1","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"inherit","header_fix":"","notify_animate_hide":"1","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#333333","show_once_yn":"","show_once":"10000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=2.1.1' id='cookie-law-info-js'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js?ver=1.5.7#property=59bef23fd022ae0011cd882a&#038;product=inline-wp-buttons' id='share-this-share-buttons-mu-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/themes/publisher/includes/libs/better-framework/assets/js/html5shiv.min.js?ver=3.15.0' id='bf-html5shiv-js'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/themes/publisher/includes/libs/better-framework/assets/js/respond.min.js?ver=3.15.0' id='bf-respond-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://nehandatv.com/wp-json/" /><link rel="alternate" type="application/json" href="https://nehandatv.com/wp-json/wp/v2/posts/60351" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nehandatv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nehandatv.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://nehandatv.com/?p=60351' />
<link rel="alternate" type="application/json+oembed" href="https://nehandatv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnehandatv.com%2F2022%2F03%2F16%2Fleonard-zhakata-chero-kuchibva-cash-official-music-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nehandatv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnehandatv.com%2F2022%2F03%2F16%2Fleonard-zhakata-chero-kuchibva-cash-official-music-video%2F&#038;format=xml" />
<script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '9fdc5c7e17'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://nehandatv.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});
_taboola.push({additional_data:{sdkd:{
    "os" : "Wordpress",
    "osv" : "5.9.2",
    "sdkt" : "Taboola Wordpress Plugin",
    "sdkv" : "1.0.9"
}}});
!function (e, f, u) {
	e.async = 1;
  e.src = u;
  f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/gandaco-nehandatv/loader.js');
</script><style type='text/css'>img#wpstats{display:none}</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9836702761589703",
          enable_page_level_ads: true,
    overlays: {bottom: true}
     });
</script>
<script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=59bef23fd022ae0011cd882a&product=inline-share-buttons-wp"></script>
<meta name="google-site-verification" content="s5gP_JiEVy8xPHeYem8fJMNLKiyx542BXp6nsYpzqW0" />
<link rel="manifest" href="/manifest.json" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(function() {
    OneSignal.init({
      appId: "79c8c945-5a74-4e3e-a447-421f8b89a839",
    });
  });
</script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gandaco-nehandatv/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script> <meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://nehandatv.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '79c8c945-5a74-4e3e-a447-421f8b89a839';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://nehandatv.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<script type="application/ld+json">{
    "@context": "http://schema.org/",
    "@type": "Organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/04/NehandaTVNewLogo-524x180.png"
    },
    "url": "https://nehandatv.com/",
    "name": "Nehanda TV",
    "description": "Videos for Zimbabwe by Zimbabweans"
}</script>
<script type="application/ld+json">{
    "@context": "http://schema.org/",
    "@type": "WebSite",
    "name": "Nehanda TV",
    "alternateName": "Videos for Zimbabwe by Zimbabweans",
    "url": "https://nehandatv.com/"
}</script>
<script type="application/ld+json">{
    "@context": "http://schema.org/",
    "@type": "BlogPosting",
    "headline": "Leonard Zhakata - Chero Kuchibva Cash (Official Music Video)",
    "description": "The evergreen Leonard Zhakata with his official video for the song \"Chero Kuchibva Cash.\"",
    "datePublished": "2022-03-16",
    "dateModified": "2022-03-16",
    "author": {
        "@type": "Person",
        "@id": "#person-NehandaTV",
        "name": "Nehanda TV"
    },
    "image": "https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg?fit=1280%2C720&ssl=1",
    "interactionStatistic": [
        {
            "@type": "InteractionCounter",
            "interactionType": "http://schema.org/CommentAction",
            "userInteractionCount": "4"
        }
    ],
    "publisher": {
        "@id": "#organization"
    },
    "mainEntityOfPage": "https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/"
}</script>
<link rel='stylesheet' id='bf-minifed-css-1' href='https://149516129.v2.pressablecdn.com/wp-content/bs-booster-cache/e47df0562d34402a49d7b922f99e205a.css' type='text/css' media='all' />
<link rel='stylesheet' id='7.11.0-1647546158' href='https://149516129.v2.pressablecdn.com/wp-content/bs-booster-cache/6d8ef2c12981173b6401f2e55506b8ed.css' type='text/css' media='all' />
<link rel="icon" href="https://i0.wp.com/nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512.jpg?fit=270%2C270&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> </head>
<body class="post-template-default single single-post postid-60351 single-format-standard bs-theme bs-publisher bs-publisher-clean-magazine active-light-box active-top-line ltr close-rh page-layout-2-col page-layout-2-col-right full-width main-menu-sticky-smart main-menu-full-width active-ajax-search single-cat-7 single-prim-cat-10 single-cat-10 single-cat-11 single-cat-1807  bs-hide-ha wpb-js-composer js-comp-ver-6.7.0 vc_responsive bs-ll-a" dir="ltr">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="off-canvas-overlay"></div>
<div class="off-canvas-container left skin-white">
<div class="off-canvas-inner">
<span class="canvas-close"><i></i></span>
<div class="off-canvas-header">
<div class="site-description">Videos for Zimbabwe by Zimbabweans</div>
</div>
<div class="off-canvas-search">
<form role="search" method="get" action="https://nehandatv.com">
<input type="text" name="s" value="" placeholder="Search...">
<i class="fa fa-search"></i>
</form>
</div>
<nav class="off-canvas-menu">
<ul class="menu bsm-pure clearfix">
<li id="menu-item-52787" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home better-anim-fade menu-item-52787"><a href="https://nehandatv.com/">Home</a></li>
<li id="menu-item-1555" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-11 better-anim-fade menu-item-1555"><a href="https://nehandatv.com/category/news/">News</a></li>
<li id="menu-item-1552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-1552"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li id="menu-item-52786" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-1807 better-anim-fade menu-item-52786"><a href="https://nehandatv.com/category/showbiz/">Showbiz</a></li>
<li id="menu-item-1556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-13 better-anim-fade menu-item-1556"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li id="menu-item-10924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-15 better-anim-fade menu-item-10924"><a href="https://nehandatv.com/category/sports/">Sports</a></li>
<li id="menu-item-1551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-1551"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
<li id="menu-item-1563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-5 better-anim-fade menu-item-1563"><a href="https://nehandatv.com/category/crime/">Crime &amp; Courts</a></li>
<li id="menu-item-1554" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-10 better-anim-fade menu-item-1554"><a href="https://nehandatv.com/category/music/">Music</a></li>
<li id="menu-item-10925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-10925"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
<li id="menu-item-1557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-8 better-anim-fade menu-item-1557"><a href="https://nehandatv.com/category/interviews/">Interviews</a></li>
<li id="menu-item-52788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-14 better-anim-fade menu-item-52788"><a href="https://nehandatv.com/category/religious/">Religious</a></li>
</ul>
</nav>
<div class="off_canvas_footer">
<div class="off_canvas_footer-info entry-content">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button colored in-4-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-title"> Likes </span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-title"> Subscribers </span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item rss"><a href="https://nehandatv.com/feed/rss/" target="_blank"> <i class="item-icon bsfi-rss"></i><span class="item-title"> Subscribe </span> </a> </li> </ul>
</div>
</div>
</div>
</div>
</div>
<div class="main-wrap content-main-wrap">
<header id="header" class="site-header header-style-2 full-width" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<section class="topbar topbar-style-1 hidden-xs hidden-xs">
<div class="content-wrap">
<div class="container">
<div class="topbar-inner clearfix">
<div class="section-links">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button not-colored in-4-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-title"> Likes </span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-title"> Subscribers </span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-title"> Followers </span> </a> </li> </ul>
</div>
<a class="topbar-sign-in behind-social" data-toggle="modal" data-target="#bsLoginModal">
<i class="fa fa-user-circle"></i> Sign in </a>
<div class="modal sign-in-modal fade" id="bsLoginModal" tabindex="-1" role="dialog" style="display: none">
<div class="modal-dialog" role="document">
<div class="modal-content">
<span class="close-modal" data-dismiss="modal" aria-label="Close"><i class="fa fa-close"></i></span>
<div class="modal-body">
<div id="form_17572_" class="bs-shortcode bs-login-shortcode ">
<div class="bs-login bs-type-login" style="display:none">
<div class="bs-login-panel bs-login-sign-panel bs-current-login-panel">
<form name="loginform" action="https://nehandatv.com/wp-login.php" method="post">
<div class="login-header">
<span class="login-icon fa fa-user-circle main-color"></span>
<p>Welcome, Login to your account.</p>
</div>
<div class="login-field login-username">
<input type="text" name="log" id="form_17572_user_login" class="input" value="" size="20" placeholder="Username or Email..." required />
</div>
<div class="login-field login-password">
<input type="password" name="pwd" id="form_17572_user_pass" class="input" value="" size="20" placeholder="Password..." required />
</div>
<div class="login-field">
<a href="https://nehandatv.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fnehandatv.com%2F2022%2F03%2F16%2Fleonard-zhakata-chero-kuchibva-cash-official-music-video%2F" class="go-reset-panel">Forget password?</a>
<span class="login-remember">
<input class="remember-checkbox" name="rememberme" type="checkbox" id="form_17572_rememberme" value="forever" />
<label class="remember-label">Remember me</label>
</span>
</div>
<div class="login-field login-submit">
<input type="submit" name="wp-submit" class="button-primary login-btn" value="Log In" />
<input type="hidden" name="redirect_to" value="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/" />
</div>
</form>
</div>
<div class="bs-login-panel bs-login-reset-panel">
<span class="go-login-panel"><i class="fa fa-angle-left"></i> Sign in</span>
<div class="bs-login-reset-panel-inner">
<div class="login-header">
<span class="login-icon fa fa-support"></span>
<p>Recover your password.</p>
<p>A password will be e-mailed to you.</p>
</div>
<form name="lostpasswordform" id="form_17572_lostpasswordform" action="https://nehandatv.com/wp-login.php?action=lostpassword" method="post">
<div class="login-field reset-username">
<input type="text" name="user_login" class="input" value="" placeholder="Username or Email..." required />
</div>
<div class="login-field reset-submit">
<input type="hidden" name="redirect_to" value="" />
<input type="submit" name="wp-submit" class="login-btn" value="Send My Password" />
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="section-menu">
<div id="menu-top" class="menu top-menu-wrapper" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<nav class="top-menu-container">
<ul id="top-navigation" class="top-menu menu clearfix bsm-pure">
<li id="topbar-date" class="menu-item menu-item-date">
<span class="topbar-date">Thursday, March 17, 2022</span>
</li>
<li id="menu-item-12172" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-12172"><a href="https://nehandatv.com/about-us/">About Us</a></li>
<li id="menu-item-15822" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-15822"><a href="https://nehandatv.com/contact-us-2/">Contact us</a></li>
<li id="menu-item-7934" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-7934"><a href="https://nehandatv.com/advertising/">Advertising</a></li>
<li id="menu-item-38970" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-38970"><a href="https://nehandatv.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-22541" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22541"><a href="http://nehandaradio.com/">Nehanda Radio</a></li>
<li id="menu-item-22542" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22542"><a href="http://tellyafrica.com/">Telly Africa</a></li>
<li id="menu-item-58533" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58533"><a href="https://dailymast.com/">Daily Mast</a></li>
<li id="menu-item-58532" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58532"><a href="https://footyhawk.com/">Footy Hawk</a></li>
</ul>
</nav>
</div>
</div>
</div>
</div>
</div>
</section>
<div class="header-inner">
<div class="content-wrap">
<div class="container">
<div class="row">
<div class="row-height">
<div class="logo-col col-xs-4">
<div class="col-inside">
<div id="site-branding" class="site-branding">
<p id="site-title" class="logo h1 img-logo">
<a href="https://nehandatv.com/" itemprop="url" rel="home">
<img id="site-logo" src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/04/NehandaTVNewLogo-524x180.png" alt="Publisher" data-bsrjs="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/04/NehandaTVNewLogo-524x180.png" />
<span class="site-title">Publisher - Videos for Zimbabwe by Zimbabweans</span>
</a>
</p>
</div>
</div>
</div>
<div class="sidebar-col col-xs-8">
<div class="col-inside">
<aside id="sidebar" class="sidebar" role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div class="bzx bzx-pubadban bzx-show-desktop bzx-show-tablet-portrait bzx-show-tablet-landscape bzx-show-phone bzx-loc-header_aside_logo bzx-align-center bzx-column-1 bzx-clearfix no-bg-box-model"><div id="bzx-53404-925128326" class="bzx-container bzx-type-image " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="53404" data-type="image"><a itemprop="url" class="bzx-link" href="https://dailymast.com/" target="_blank"><img class="bzx-image" src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2020/05/TV-and-Showbiz.png" alt="Daily Mast Advert" /></a></div></div> </aside>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="menu-main" class="menu main-menu-wrapper show-search-item show-off-canvas menu-actions-btn-width-2" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="main-menu-inner">
<div class="content-wrap">
<div class="container">
<nav class="main-menu-container">
<ul id="main-navigation" class="main-menu menu bsm-pure clearfix">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home better-anim-fade menu-item-52787"><a href="https://nehandatv.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-11 better-anim-fade menu-item-1555"><a href="https://nehandatv.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-1552"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-1807 better-anim-fade menu-item-52786"><a href="https://nehandatv.com/category/showbiz/">Showbiz</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-13 better-anim-fade menu-item-1556"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-15 better-anim-fade menu-item-10924"><a href="https://nehandatv.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-1551"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-5 better-anim-fade menu-item-1563"><a href="https://nehandatv.com/category/crime/">Crime &amp; Courts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-10 better-anim-fade menu-item-1554"><a href="https://nehandatv.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-10925"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-8 better-anim-fade menu-item-1557"><a href="https://nehandatv.com/category/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-14 better-anim-fade menu-item-52788"><a href="https://nehandatv.com/category/religious/">Religious</a></li>
</ul>
<div class="menu-action-buttons width-2">
<div class="off-canvas-menu-icon-container off-icon-left">
<div class="off-canvas-menu-icon">
<div class="off-canvas-menu-icon-el"></div>
</div>
</div>
<div class="search-container close">
<span class="search-handler"><i class="fa fa-search"></i></span>
<div class="search-box clearfix">
<form role="search" method="get" class="search-form clearfix" action="https://nehandatv.com">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" autocomplete="off">
<input type="submit" class="search-submit" value="Search">
</form>
</div>
</div>
</div>
</nav>
</div>
</div>
</div>
</div>
</header>
<div class="rh-header clearfix light deferred-block-exclude">
<div class="rh-container clearfix">
<div class="menu-container close">
<span class="menu-handler"><span class="lines"></span></span>
</div>
<div class="logo-container rh-img-logo">
<a href="https://nehandatv.com/" itemprop="url" rel="home">
<img src="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/NehandaTVlogo-300x45.png" alt="Nehanda TV" data-bsrjs="https://149516129.v2.pressablecdn.com/wp-content/uploads/2019/05/NehandaTVlogo2.png" /> </a>
</div>
</div>
</div>
<div class="container adcontainer"><div class="bzx bzx-after-header bzx-pubadban bzx-show-desktop bzx-show-tablet-portrait bzx-show-tablet-landscape bzx-show-phone bzx-loc-header_after bzx-align-center bzx-column-1 bzx-clearfix no-bg-box-model"><div id="bzx-27187-1627720121" class="bzx-container bzx-type-code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="27187" data-type="code"><div id="bzx-27187-1627720121-place"></div><script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('bzx-27187-1627720121');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('bzx-27187-1627720121-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('bzx-27187-1627720121-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('bzx-27187-1627720121-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width < 768 ) { document.getElementById('bzx-27187-1627720121-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}</script></div></div></div><div class="content-wrap">
<main id="content" class="content-container">
<div class="container layout-2-col layout-2-col-1 layout-right-sidebar post-template-10">
<div class="row main-section">
<div class="col-sm-8 content-column">
<div class="single-container">
<article id="post-60351" class="post-60351 post type-post status-publish format-standard has-post-thumbnail  category-featured category-music category-news category-showbiz tag-leonard-zhakata single-post-content">
<div class="single-featured"></div>
<div class="post-header-inner">
<div class="post-header-title">
<div class="term-badges floated"><span class="term-badge term-10"><a href="https://nehandatv.com/category/music/">Music</a></span><span class="term-badge term-7"><a href="https://nehandatv.com/category/featured/">Featured</a></span><span class="term-badge term-11"><a href="https://nehandatv.com/category/news/">News</a></span></div> <h1 class="single-post-title">
<span class="post-title" itemprop="headline">Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)</span>
</h1>
<div class="post-meta single-post-meta">
<a href="https://nehandatv.com/author/kaguvi/" title="Browse Author Articles" class="post-author-a post-author-avatar">
<img alt='' data-src='https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=26&d=mm&r=g' class='avatar avatar-26 photo avatar-default' height='26' width='26' /><span class="post-author-name">By <b>Nehanda TV</b></span> </a>
<span class="time"><time class="post-published updated" datetime="2022-03-16T19:28:19+02:00">On <b>Mar 16, 2022</b></time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60351"><i class="bf-icon  bsfi-fire-4"></i> 5,774</span><a href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#disqus_thread" title="Leave a comment on: &ldquo;Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a></div>
</div>
</div>
<div class="entry-content clearfix single-post-content">
<div style="margin-top: 0px; margin-bottom: 0px;" class="sharethis-inline-share-buttons"></div><p><strong>The evergreen Leonard Zhakata with his official video for the song &#8220;Chero Kuchibva Cash.&#8221;</strong></p>
<p><iframe title="Leonard Zhakata - Chero Kuchibva Cash (Official Music Video)" width="1170" height="658" src="https://www.youtube.com/embed/Fv5HpcKYLrU?wmode=transparent&amp;rel=0&amp;feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>Executive producer: Albert Mtengwa, Audio producer: Macdonald Macdee Chidavaenzi (Eternity productions) and Visuals produced by: Mr Hasty(Rocklife Media).</p>
<div class="946dfb7d95b85a3aac31246e44da1f35" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9836702761589703" data-ad-slot="2408623768" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({mode:'thumbnails-b', container:'taboola-below-article', placement:'below-article', target_type: 'mix'});</script><div class="bzx bzx-post-bottom bzx-float-center bzx-align-center bzx-column-1 bzx-clearfix no-bg-box-model"><div id="bzx-30798-769530880" class="bzx-container bzx-type-code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="30798" data-type="code"><div id="bzx-30798-769530880-place"></div><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('bzx-30798-769530880');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('bzx-30798-769530880-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('bzx-30798-769530880-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('bzx-30798-769530880-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width < 768 ) { document.getElementById('bzx-30798-769530880-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}</script></div></div> </div>
<div class="entry-terms post-tags clearfix ">
<span class="terms-label"><i class="fa fa-tags"></i></span>
<a href="https://nehandatv.com/tag/leonard-zhakata/" rel="tag">Leonard Zhakata</a> </div>
</article>
<section class="next-prev-post clearfix">
<div class="prev-post">
<p class="pre-title heading-typo"><i class="fa fa-arrow-left"></i> Prev Post </p>
<p class="title heading-typo"><a href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/" rel="prev">Shadaya Knight on Olinda, Stunner, MisRed, his views on Women | The Denny J Show</a></p>
</div>
</section>
</div>
<div class="post-related">
<div class="section-heading sh-t1 sh-s1 multi-tab">
<a href="#relatedposts_158599103_1" class="main-link active" data-toggle="tab">
<span class="h-text related-posts-heading">You might also like</span>
</a>
<a href="#relatedposts_158599103_2" class="other-link" data-toggle="tab" data-deferred-event="shown.bs.tab" data-deferred-init="relatedposts_158599103_2">
<span class="h-text related-posts-heading">More from author</span>
</a>
</div>
<div class="tab-content">
<div class="tab-pane bs-tab-anim bs-tab-animated active" id="relatedposts_158599103_1">
<div class="bs-pagination-wrapper main-term-none next_prev ">
<div class="listing listing-thumbnail listing-tb-2 clearfix  scolumns-2 simple-grid">
<div class="post-37544 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-2 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<div class="term-badges floated"><span class="term-badge term-10"><a href="https://nehandatv.com/category/music/">Music</a></span></div> <a title="WATCH: Leonard Zhakata performs &#8216;Mugove&#8217; at Winter Warmer Concert" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2018/06/Screen-Shot-2018-06-22-at-16.18.55.png?resize=210%2C136&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2018\/06\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;Screen-Shot-2018-06-22-at-16.18.55-86x64.png&quot;,&quot;210&quot;:&quot;Screen-Shot-2018-06-22-at-16.18.55-210x136.png&quot;,&quot;279&quot;:&quot;Screen-Shot-2018-06-22-at-16.18.55-279x220.png&quot;,&quot;357&quot;:&quot;Screen-Shot-2018-06-22-at-16.18.55-357x210.png&quot;,&quot;653&quot;:&quot;Screen-Shot-2018-06-22-at-16.18.55.png&quot;}}" class="img-holder" href="https://nehandatv.com/2018/06/22/watch-leonard-zhakata-performs-mugove-at-winter-warmer-concert/"></a>
</div>
<p class="title"> <a class="post-url" href="https://nehandatv.com/2018/06/22/watch-leonard-zhakata-performs-mugove-at-winter-warmer-concert/" title="WATCH: Leonard Zhakata performs &#8216;Mugove&#8217; at Winter Warmer Concert">
<span class="post-title">
WATCH: Leonard Zhakata performs &#8216;Mugove&#8217; at Winter Warmer Concert </span>
</a>
</p></div>
</div >
<div class="post-37224 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-2 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<div class="term-badges floated"><span class="term-badge term-10"><a href="https://nehandatv.com/category/music/">Music</a></span></div> <a title="WATCH: Zhakata performing at Macheso album launch" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2018/06/watch-zhakata-performing-at-mach.jpg?resize=210%2C136&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2018\/06\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;watch-zhakata-performing-at-mach-86x64.jpg&quot;,&quot;210&quot;:&quot;watch-zhakata-performing-at-mach-210x136.jpg&quot;,&quot;279&quot;:&quot;watch-zhakata-performing-at-mach-279x220.jpg&quot;,&quot;357&quot;:&quot;watch-zhakata-performing-at-mach-357x210.jpg&quot;,&quot;480&quot;:&quot;watch-zhakata-performing-at-mach.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2018/06/13/watch-zhakata-performing-at-macheso-album-launch/"></a>
</div>
<p class="title"> <a class="post-url" href="https://nehandatv.com/2018/06/13/watch-zhakata-performing-at-macheso-album-launch/" title="WATCH: Zhakata performing at Macheso album launch">
<span class="post-title">
WATCH: Zhakata performing at Macheso album launch </span>
</a>
</p></div>
</div >
</div>
</div>
</div>
<div class="tab-pane bs-tab-anim bs-tab-animated bs-deferred-container" id="relatedposts_158599103_2">
<div class="bs-pagination-wrapper main-term-none next_prev ">
<div class="bs-deferred-load-wrapper" id="bsd_relatedposts_158599103_2">
<script>var bs_deferred_loading_bsd_relatedposts_158599103_2 = '{"query":{"paginate":"next_prev","count":4,"author":1,"post_type":"post","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::fetch_other_related_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"78a6ae9"}';</script>
</div>
</div> </div>
</div>
</div>
<section id="comments-template-60351" class="comments-template comment-respond">
<div class="section-heading sh-t1 sh-s1"><span class="h-text">Comments</span>
</div>
<div id="comments" class="better-comments-area better-disqus-comments-area">
<div id="disqus_thread" data-post-id="60351"></div>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus</a>.</noscript>
</div>
</section>
</div>
<div class="col-sm-4 sidebar-column sidebar-column-primary">
<aside id="sidebar-primary-sidebar" class="sidebar" role="complementary" aria-label="Primary Sidebar Sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div id="block-2" class=" h-ni w-nt primary-sidebar-widget widget widget_block widget_search"><form role="search" method="get" action="https://nehandatv.com/" class="wp-block-search__button-outside wp-block-search__text-button wp-block-search"><label for="wp-block-search__input-1" class="wp-block-search__label">Search</label><div class="wp-block-search__inside-wrapper "><input type="search" id="wp-block-search__input-1" class="wp-block-search__input " name="s" value="" placeholder="" required /><button type="submit" class="wp-block-search__button  ">Search</button></div></form></div><div id="bzx-17" class=" h-ni w-nt primary-sidebar-widget widget widget_bzx"><div class="bzx  bzx-align-center bzx-column-1 bzx-clearfix no-bg-box-model"><div id="bzx-45102-31158915" class="bzx-container bzx-type-code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="45102" data-type="code"><div id="bzx-45102-31158915-place"></div><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('bzx-45102-31158915');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('bzx-45102-31158915-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="9339965881"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('bzx-45102-31158915-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="9339965881"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('bzx-45102-31158915-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="9339965881"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width < 768 ) { document.getElementById('bzx-45102-31158915-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="9339965881"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}</script></div></div></div><div id="bs-thumbnail-listing-1-2" class=" h-ni w-t primary-sidebar-widget widget widget_bs-thumbnail-listing-1"><div class=" bs-listing bs-listing-listing-thumbnail-1 bs-listing-single-tab pagination-animate"> <p class="section-heading sh-t1 sh-s1 main-term-none">
<span class="h-text main-term-none main-link">
Recent Videos </span>
</p>
<div class="bs-pagination-wrapper main-term-none more_btn bs-slider-first-item">
<div class="listing listing-thumbnail listing-tb-1 clearfix columns-1">
<div class="post-60351 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU-86x64.jpg&quot;,&quot;210&quot;:&quot;leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU-210x136.jpg&quot;,&quot;1280&quot;:&quot;leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/" class="post-url post-title">
Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-16T19:28:19+02:00">Mar 16, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60351"><i class="bf-icon  bsfi-fire-4"></i>5,774</span><a href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#disqus_thread" title="Leave a comment on: &ldquo;Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60347 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-1807">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Shadaya Knight on Olinda, Stunner, MisRed, his views on Women | The Denny J Show" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo-86x64.jpg&quot;,&quot;210&quot;:&quot;shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo-210x136.jpg&quot;,&quot;480&quot;:&quot;shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/" class="post-url post-title">
Shadaya Knight on Olinda, Stunner, MisRed, his views on&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-16T19:05:07+02:00">Mar 16, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60347"><i class="bf-icon  bsfi-fire-4"></i>11,167</span><a href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/#disqus_thread" title="Leave a comment on: &ldquo;Shadaya Knight on Olinda, Stunner, MisRed, his views on Women | The Denny J Show&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60344 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-11367">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Jonathan Pie: How Putin weaponized London’s greed | NYT Opinion" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE-86x64.jpg&quot;,&quot;210&quot;:&quot;jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE-210x136.jpg&quot;,&quot;1280&quot;:&quot;jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/13/jonathan-pie-how-putin-weaponized-londons-greed-nyt-opinion/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/13/jonathan-pie-how-putin-weaponized-londons-greed-nyt-opinion/" class="post-url post-title">
Jonathan Pie: How Putin weaponized London’s greed | NYT&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-13T15:46:38+02:00">Mar 13, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60344"><i class="bf-icon  bsfi-fire-4"></i>35,547</span><a href="https://nehandatv.com/2022/03/13/jonathan-pie-how-putin-weaponized-londons-greed-nyt-opinion/#disqus_thread" title="Leave a comment on: &ldquo;Jonathan Pie: How Putin weaponized London’s greed | NYT Opinion&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60338 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-1807">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Ruvheneko announces &#8216;perfectly imperfect&#8217; pregnancy in 4 minute VIDEO" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/ruvheneko-announces-8216-perfectly-imperfect-8217-pregnancy-in-4-minute-8216-motherhood-8217-video-eQiUIlVuN8s.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;ruvheneko-announces-8216-perfectly-imperfect-8217-pregnancy-in-4-minute-8216-motherhood-8217-video-eQiUIlVuN8s-86x64.jpg&quot;,&quot;210&quot;:&quot;ruvheneko-announces-8216-perfectly-imperfect-8217-pregnancy-in-4-minute-8216-motherhood-8217-video-eQiUIlVuN8s-210x136.jpg&quot;,&quot;1280&quot;:&quot;ruvheneko-announces-8216-perfectly-imperfect-8217-pregnancy-in-4-minute-8216-motherhood-8217-video-eQiUIlVuN8s.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/05/ruvheneko-announces-perfectly-imperfect-pregnancy-in-4-minute-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/05/ruvheneko-announces-perfectly-imperfect-pregnancy-in-4-minute-video/" class="post-url post-title">
Ruvheneko announces &#8216;perfectly imperfect&#8217;&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-05T14:44:23+02:00">Mar 5, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60338"><i class="bf-icon  bsfi-fire-4"></i>89,025</span><a href="https://nehandatv.com/2022/03/05/ruvheneko-announces-perfectly-imperfect-pregnancy-in-4-minute-video/#disqus_thread" title="Leave a comment on: &ldquo;Ruvheneko announces &#8216;perfectly imperfect&#8217; pregnancy in 4 minute VIDEO&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60341 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Dr Alex Magaisa gives his analysis to the SABC after US extended its sanctions on Zimbabwe" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/dr-alex-magaisa-gives-his-analysis-to-sabc-after-us-extended-its-sanctions-on-zimbabwe-nb0iVLVkIa4.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;dr-alex-magaisa-gives-his-analysis-to-sabc-after-us-extended-its-sanctions-on-zimbabwe-nb0iVLVkIa4-86x64.jpg&quot;,&quot;210&quot;:&quot;dr-alex-magaisa-gives-his-analysis-to-sabc-after-us-extended-its-sanctions-on-zimbabwe-nb0iVLVkIa4-210x136.jpg&quot;,&quot;1280&quot;:&quot;dr-alex-magaisa-gives-his-analysis-to-sabc-after-us-extended-its-sanctions-on-zimbabwe-nb0iVLVkIa4.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/05/dr-alex-magaisa-gives-his-analysis-to-the-sabc-after-us-extended-its-sanctions-on-zimbabwe/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/05/dr-alex-magaisa-gives-his-analysis-to-the-sabc-after-us-extended-its-sanctions-on-zimbabwe/" class="post-url post-title">
Dr Alex Magaisa gives his analysis to the SABC after US&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-05T14:12:02+02:00">Mar 5, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60341"><i class="bf-icon  bsfi-fire-4"></i>5,949</span><a href="https://nehandatv.com/2022/03/05/dr-alex-magaisa-gives-his-analysis-to-the-sabc-after-us-extended-its-sanctions-on-zimbabwe/#disqus_thread" title="Leave a comment on: &ldquo;Dr Alex Magaisa gives his analysis to the SABC after US extended its sanctions on Zimbabwe&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
</div>
</div><div class="bs-pagination bs-ajax-pagination more_btn main-term-none clearfix">
<script>var bs_ajax_paginate_1827918028 = '{"query":{"category":"","tag":"","taxonomy":"","post_ids":"","post_type":"","count":"5","order_by":"date","order":"DESC","time_filter":"","offset":"","style":"listing-thumbnail-1","cats-tags-condition":"and","cats-condition":"in","tags-condition":"in","featured_image":"0","ignore_sticky_posts":"1","author_ids":"","disable_duplicate":"0","ad-active":0,"paginate":"more_btn","pagination-show-label":"1","columns":1,"listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"0","share":"0","comment":"0","review":"1"}},"override-listing-settings":"0","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"bs_post_listing","view":"Publisher_Thumbnail_Listing_1_Shortcode","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"more_btn","pagination-show-label":"1","override-listing-settings":"0","listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"0","share":"0","comment":"0","review":"1"}},"columns":1,"ad-active":false,"_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"f7faa54","data":{"vars":{"post-ranking-offset":5}}}';</script> <a rel="next" class="btn-bs-pagination" data-id="1827918028" title="Load More Posts">
<span class="loading" style="display: none;">
<i class="fa fa-refresh fa-spin fa-fw"></i>
</span>
<span class="loading" style="display: none;">
Loading ... </span>
<span class="loaded txt">
Load More Posts </span>
<span class="loaded icon">
<i class="fa fa-angle-down" aria-hidden="true"></i>
</span>
<span class="no-more" style="display: none;">
No More Posts
</span>
</a>
</div></div></div><div id="better-social-counter-2" class=" h-ni w-t primary-sidebar-widget widget widget_better-social-counter"><div class="section-heading sh-t1 sh-s1"><span class="h-text">Follow us for updates</span></div> <div class="  better-studio-shortcode bsc-clearfix better-social-counter style-box colored in-2-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" class="item-link" target="_blank"><i class="item-icon bsfi-facebook"></i> <span class="item-count"> Facebook</span> <span class="item-title"> Likes</span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" class="item-link" target="_blank"><i class="item-icon bsfi-twitter"></i> <span class="item-count"> 5,523</span> <span class="item-title"> Followers</span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" class="item-link" target="_blank"><i class="item-icon bsfi-youtube"></i> <span class="item-count"> Youtube</span> <span class="item-title"> Subscribers</span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" class="item-link" target="_blank"><i class="item-icon bsfi-instagram"></i> <span class="item-count"> Instagram</span> <span class="item-title"> Followers</span> </a> </li> </ul>
</div>
</div><div id="bs-thumbnail-listing-1-3" class=" h-ni w-t primary-sidebar-widget widget widget_bs-thumbnail-listing-1"><div class=" bs-listing bs-listing-listing-thumbnail-1 bs-listing-single-tab pagination-animate"> <p class="section-heading sh-t1 sh-s1 main-term-none">
<span class="h-text main-term-none main-link">
Most Commented this Week </span>
</p>
<div class="bs-pagination-wrapper main-term-none more_btn bs-slider-first-item">
<div class="listing listing-thumbnail listing-tb-1 clearfix columns-1">
<div class="post-60351 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU-86x64.jpg&quot;,&quot;210&quot;:&quot;leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU-210x136.jpg&quot;,&quot;1280&quot;:&quot;leonard-zhakata-8211-chero-kuchibva-cash-official-music-video-Fv5HpcKYLrU.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/" class="post-url post-title">
Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-16T19:28:19+02:00">Mar 16, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60351"><i class="bf-icon  bsfi-fire-4"></i>5,774</span><a href="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/#disqus_thread" title="Leave a comment on: &ldquo;Leonard Zhakata &#8211; Chero Kuchibva Cash (Official Music Video)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60347 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-1807">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Shadaya Knight on Olinda, Stunner, MisRed, his views on Women | The Denny J Show" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo-86x64.jpg&quot;,&quot;210&quot;:&quot;shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo-210x136.jpg&quot;,&quot;480&quot;:&quot;shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show-fz-eYneDZKo.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/" class="post-url post-title">
Shadaya Knight on Olinda, Stunner, MisRed, his views on&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-16T19:05:07+02:00">Mar 16, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60347"><i class="bf-icon  bsfi-fire-4"></i>11,167</span><a href="https://nehandatv.com/2022/03/16/shadaya-knight-on-olinda-stunner-misred-his-views-on-women-the-denny-j-show/#disqus_thread" title="Leave a comment on: &ldquo;Shadaya Knight on Olinda, Stunner, MisRed, his views on Women | The Denny J Show&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-60344 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-11367">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Jonathan Pie: How Putin weaponized London’s greed | NYT Opinion" data-src="https://i0.wp.com/nehandatv.com/wp-content/uploads/2022/03/jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE.jpg?resize=86%2C64&ssl=1" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/i0.wp.com\/nehandatv.com\/wp-content\/uploads\/2022\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE-86x64.jpg&quot;,&quot;210&quot;:&quot;jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE-210x136.jpg&quot;,&quot;1280&quot;:&quot;jonathan-pie-how-putin-weaponized-london-s-greed-nyt-opinion-YAblAQENQhE.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2022/03/13/jonathan-pie-how-putin-weaponized-londons-greed-nyt-opinion/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2022/03/13/jonathan-pie-how-putin-weaponized-londons-greed-nyt-opinion/" class="post-url post-title">
Jonathan Pie: How Putin weaponized London’s greed | NYT&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2022-03-13T15:46:38+02:00">Mar 13, 2022</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="60344"><i class="bf-icon  bsfi-fire-4"></i>35,547</span><a href="https://nehandatv.com/2022/03/13/jonathan-pie-how-putin-weaponized-londons-greed-nyt-opinion/#disqus_thread" title="Leave a comment on: &ldquo;Jonathan Pie: How Putin weaponized London’s greed | NYT Opinion&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
</div>
</div></div></div><div id="bs-subscribe-newsletter-2" class=" h-ni w-t primary-sidebar-widget widget widget_bs-subscribe-newsletter"><div class="section-heading sh-t1 sh-s1"><span class="h-text">Sign up to get VIDEO alerts</span></div> <div class="bs-shortcode bs-subscribe-newsletter bs-feedburner-newsletter ">
<div class="subscribe-image">
<img src="https://149516129.v2.pressablecdn.com/wp-content/themes/publisher/images/other/email-illustration.png" alt="Sign up to get VIDEO alerts">
</div>
<div class="subscribe-message">
<p>Sign up to get VIDEO alerts</p>
</div>
<form method="post" action="//feedburner.google.com/fb/a/mailverify" class="bs-subscribe-feedburner clearfix" target="_blank">
<input type="hidden" value="nehandatv" name="uri" />
<input type="hidden" name="loc" value="en_US" />
<input type="text" id="feedburner-email" name="email" class="newsletter-email" placeholder="Enter your e-mail .." />
<button class="newsletter-subscribe" name="submit" type="submit">Subscribe</button>
</form>
</div>
</div></aside>
</div>
</div>
</div>
</main>
</div>
<footer id="site-footer" class="site-footer full-width">
<div class="footer-social-icons">
<div class="content-wrap">
<div class="container">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-big-button colored in-5-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"> <a href="https://www.facebook.com/NehandaTV" class="item-link" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-name"> Facebook</span> <span class="item-title-join"> Join us on Facebook</span> </a> </li> <li class="social-item twitter"> <a href="https://twitter.com/nehandatv" class="item-link" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-name"> Twitter</span> <span class="item-title-join"> Join us on Twitter</span> </a> </li> <li class="social-item youtube"> <a href="https://youtube.com/user/NehandaTV" class="item-link" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-name"> Youtube</span> <span class="item-title-join"> Join us on Youtube</span> </a> </li> <li class="social-item instagram"> <a href="https://instagram.com/nehandatv" class="item-link" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-name"> Instagram</span> <span class="item-title-join"> Join us on Instagram</span> </a> </li> </ul>
</div>
</div>
</div>
</div>
<div class="copy-footer">
<div class="content-wrap">
<div class="container">
<div class="row">
<div class="col-lg-12">
<div id="menu-footer" class="menu footer-menu-wrapper" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<nav class="footer-menu-container">
<ul id="footer-navigation" class="footer-menu menu clearfix">
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-12172"><a href="https://nehandatv.com/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-15822"><a href="https://nehandatv.com/contact-us-2/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-7934"><a href="https://nehandatv.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-38970"><a href="https://nehandatv.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22541"><a href="http://nehandaradio.com/">Nehanda Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22542"><a href="http://tellyafrica.com/">Telly Africa</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58533"><a href="https://dailymast.com/">Daily Mast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-58532"><a href="https://footyhawk.com/">Footy Hawk</a></li>
</ul>
</nav>
</div>
</div>
</div>
<div class="row footer-copy-row">
<div class="copy-1 col-lg-6 col-md-6 col-sm-6 col-xs-12">
© 2022 - Nehanda TV. All Rights Reserved. </div>
<div class="copy-2 col-lg-6 col-md-6 col-sm-6 col-xs-12">
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
<span class="back-top"><i class="fa fa-arrow-up"></i></span>
<!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span><div class="cli-bar-container cli-style-v2"><div class="cli-bar-message">We use cookies on our website to give you the most relevant experience by remembering your preferences and repeat visits. By clicking “Accept All”, you consent to the use of ALL the cookies. However, you may visit "Cookie Settings" to provide a controlled consent.</div><div class="cli-bar-btn_container"><a role='button' class="medium cli-plugin-button cli-plugin-main-button cli_settings_button" style="margin:0px 5px 0px 0px">Cookie Settings</a><a id="wt-cli-accept-all-btn" role='button' data-cli_action="accept_all" class="wt-cli-element medium cli-plugin-button wt-cli-accept-all-btn cookie_action_close_header cli_action_button">Accept All</a></div></div></span></div><div id="cookie-law-info-again" data-nosnippet="true"><span id="cookie_hdr_showagain">Manage consent</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
<div class="cli-modal-dialog" role="document">
<div class="cli-modal-content cli-bar-popup">
<button type="button" class="cli-modal-close" id="cliModalClose">
<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
<span class="wt-cli-sr-only">Close</span>
</button>
<div class="cli-modal-body">
<div class="cli-container-fluid cli-tab-container">
<div class="cli-row">
<div class="cli-col-12 cli-align-items-stretch cli-px-0">
<div class="cli-privacy-overview">
<h4>Privacy Overview</h4> <div class="cli-privacy-content">
<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may affect your browsing experience.</div>
</div>
<a class="cli-privacy-readmore" aria-label="Show more" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a> </div>
</div>
<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
<div class="cli-tab-section">
<div class="cli-tab-header">
<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
Necessary </a>
<div class="wt-cli-necessary-checkbox">
<input type="checkbox" class="cli-user-preference-checkbox" id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked" />
<label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
</div>
<span class="cli-necessary-caption">Always Enabled</span>
</div>
<div class="cli-tab-content">
<div class="cli-tab-pane cli-fade" data-id="necessary">
<div class="wt-cli-cookie-description">
Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information. </div>
</div>
</div>
</div>
<div class="cli-tab-section">
<div class="cli-tab-header">
<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab">
Non-necessary </a>
<div class="cli-switch">
<input type="checkbox" id="wt-cli-checkbox-non-necessary" class="cli-user-preference-checkbox" data-id="checkbox-non-necessary" checked='checked' />
<label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Non-necessary</span></label>
</div>
</div>
<div class="cli-tab-content">
<div class="cli-tab-pane cli-fade" data-id="non-necessary">
<div class="wt-cli-cookie-description">
Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website. </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="cli-modal-footer">
<div class="wt-cli-element cli-container-fluid cli-tab-container">
<div class="cli-row">
<div class="cli-col-12 cli-align-items-stretch cli-px-0">
<div class="cli-tab-footer wt-cli-privacy-overview-actions">
<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE &amp; ACCEPT</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all--><div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({flush: true});</script><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-49233918-3', 'auto');
  ga('send', 'pageview');

</script><script id='publisher-theme-pagination-js-extra'>
var bs_pagination_loc = {"loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>"};
</script>
<script id='publisher-js-extra'>
var publisher_theme_global_loc = {"page":{"boxed":"full-width"},"header":{"style":"style-2","boxed":"full-width"},"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>","translations":{"tabs_all":"All","tabs_more":"More","lightbox_expand":"Expand the image","lightbox_close":"Close"},"lightbox":{"not_classes":""},"main_menu":{"more_menu":"enable"},"top_menu":{"more_menu":"enable"},"skyscraper":{"sticky_gap":30,"sticky":true,"position":""},"share":{"more":false},"refresh_googletagads":"1","get_locale":"en-US","notification":{"subscribe_msg":"By clicking the subscribe button you will never miss the new articles!","subscribed_msg":"You're subscribed to notifications","subscribe_btn":"Subscribe","subscribed_btn":"Unsubscribe"}};
var publisher_theme_ajax_search_loc = {"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","previewMarkup":"<div class=\"ajax-search-results-wrapper ajax-search-no-product ajax-search-fullwidth\">\n\t<div class=\"ajax-search-results\">\n\t\t<div class=\"ajax-ajax-posts-list\">\n\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t<span>Posts<\/span>\n\t\t\t<\/div>\n\t\t\t<div class=\"posts-lists\" data-section-name=\"posts\"><\/div>\n\t\t<\/div>\n\t\t<div class=\"ajax-taxonomy-list\">\n\t\t\t<div class=\"ajax-categories-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Categories<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"categories\"><\/div>\n\t\t\t<\/div>\n\t\t\t<div class=\"ajax-tags-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Tags<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"tags\"><\/div>\n\t\t\t<\/div>\n\t\t<\/div>\n\t<\/div>\n<\/div>","full_width":"1"};
</script>
<div class="rh-cover noscroll gr-8 no-top-nav">
<span class="rh-close"></span>
<div class="rh-panel rh-pm">
<div class="rh-p-h">
<span class="user-login">
<span class="user-avatar user-avatar-icon"><i class="fa fa-user-circle"></i></span>
Sign in </span> </div>
<div class="rh-p-b">
<div class="rh-c-m clearfix"><ul id="resp-navigation" class="resp-menu menu clearfix"><li id="menu-item-57322" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-11 better-anim-fade menu-item-57322"><a href="https://nehandatv.com/category/news/">News</a></li>
<li id="menu-item-57314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-57314"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li id="menu-item-57315" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-term-10 better-anim-fade menu-item-57315"><a href="https://nehandatv.com/category/music/">Music</a>
<ul class="sub-menu">
<li id="menu-item-57320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-57320"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
</ul>
</li>
<li id="menu-item-57316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-13 better-anim-fade menu-item-57316"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li id="menu-item-57317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-14 better-anim-fade menu-item-57317"><a href="https://nehandatv.com/category/religious/">Religious</a></li>
<li id="menu-item-57318" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-1807 better-anim-fade menu-item-57318"><a href="https://nehandatv.com/category/showbiz/">Showbiz</a></li>
<li id="menu-item-57319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-term-8158 better-anim-fade menu-item-57319"><a href="https://nehandatv.com/category/local/">Local</a>
<ul class="sub-menu">
<li id="menu-item-57321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-57321"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
</ul>
</li>
</ul></div>
<form role="search" method="get" class="search-form" action="https://nehandatv.com">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" autocomplete="off">
<input type="submit" class="search-submit" value="">
</form>
</div>
</div>
<div class="rh-panel rh-p-u">
<div class="rh-p-h">
<span class="rh-back-menu"><i></i></span>
</div>
<div class="rh-p-b">
<div id="form_17266_" class="bs-shortcode bs-login-shortcode ">
<div class="bs-login bs-type-login" style="display:none">
<div class="bs-login-panel bs-login-sign-panel bs-current-login-panel">
<form name="loginform" action="https://nehandatv.com/wp-login.php" method="post">
<div class="login-header">
<span class="login-icon fa fa-user-circle main-color"></span>
<p>Welcome, Login to your account.</p>
</div>
<div class="login-field login-username">
<input type="text" name="log" id="form_17266_user_login" class="input" value="" size="20" placeholder="Username or Email..." required />
</div>
<div class="login-field login-password">
<input type="password" name="pwd" id="form_17266_user_pass" class="input" value="" size="20" placeholder="Password..." required />
</div>
<div class="login-field">
<a href="https://nehandatv.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fnehandatv.com%2F2022%2F03%2F16%2Fleonard-zhakata-chero-kuchibva-cash-official-music-video%2F" class="go-reset-panel">Forget password?</a>
<span class="login-remember">
<input class="remember-checkbox" name="rememberme" type="checkbox" id="form_17266_rememberme" value="forever" />
<label class="remember-label">Remember me</label>
</span>
</div>
<div class="login-field login-submit">
<input type="submit" name="wp-submit" class="button-primary login-btn" value="Log In" />
<input type="hidden" name="redirect_to" value="https://nehandatv.com/2022/03/16/leonard-zhakata-chero-kuchibva-cash-official-music-video/" />
</div>
</form>
</div>
<div class="bs-login-panel bs-login-reset-panel">
<span class="go-login-panel"><i class="fa fa-angle-left"></i> Sign in</span>
<div class="bs-login-reset-panel-inner">
<div class="login-header">
<span class="login-icon fa fa-support"></span>
<p>Recover your password.</p>
<p>A password will be e-mailed to you.</p>
</div>
<form name="lostpasswordform" id="form_17266_lostpasswordform" action="https://nehandatv.com/wp-login.php?action=lostpassword" method="post">
<div class="login-field reset-username">
<input type="text" name="user_login" class="input" value="" placeholder="Username or Email..." required />
</div>
<div class="login-field reset-submit">
<input type="hidden" name="redirect_to" value="" />
<input type="submit" name="wp-submit" class="login-btn" value="Send My Password" />
</div>
</form>
</div>
</div>
</div>
</div> </div>
</div>
</div>
<link rel='stylesheet' id='modal-css' href='https://149516129.v2.pressablecdn.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.25' type='text/css' media='all' />
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' id='better-post-views-cache-js-extra'>
/* <![CDATA[ */
var better_post_views_vars = {"admin_ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","post_id":"60351"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/better-post-views/js/better-post-views.min.js?ver=1.6.0' id='better-post-views-cache-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"nehandatv"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"60351 https:\/\/nehandatv.com\/?p=60351","disqusShortname":"nehandatv","disqusTitle":"Leonard Zhakata \u2013 Chero Kuchibva Cash (Official Music Video)","disqusUrl":"https:\/\/nehandatv.com\/2022\/03\/16\/leonard-zhakata-chero-kuchibva-cash-official-music-video\/","postId":"60351"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=ba2aa80003251440130b63de19cb609d' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=ae8c0bea6a07ab76470a02053fc74216' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.2/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.25' id='modal-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.2' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' src='https://149516129.v2.pressablecdn.com/wp-content/plugins/better-adsmanager/js/advertising.min.js?ver=1.21.0' id='better-advertising-js'></script>
<script type='text/javascript' async="async" src='https://149516129.v2.pressablecdn.com/wp-content/bs-booster-cache/5cca18bc8d1be673067f07e55600ac58.js?ver=5.9.2' id='bs-booster-js'></script>
<script type="text/javascript">
			(function() {
			var t   = document.createElement( 'script' );
			t.type  = 'text/javascript';
			t.async = true;
			t.id    = 'gauges-tracker';
			t.setAttribute( 'data-site-id', '5fc540f6a86b8824c70ba09c' );
			t.src = '//secure.gaug.es/track.js';
			var s = document.getElementsByTagName( 'script' )[0];
			s.parentNode.insertBefore( t, s );
			})();
		</script>
<script>
var bzx=function(t){"use strict";return{init:function(){0==bzx.ads_state()&&bzx.blocked_ads_fallback()},ads_state:function(){return void 0!==window.better_ads_adblock},blocked_ads_fallback:function(){var a=[];t(".bzx-container").each(function(){if("image"==t(this).data("type"))return 0;a.push({element_id:t(this).attr("id"),ad_id:t(this).data("adid")})}),a.length<1||jQuery.ajax({url:'https://nehandatv.com/wp-admin/admin-ajax.php',type:"POST",data:{action:"better_ads_manager_blocked_fallback",ads:a},success:function(a){var e=JSON.parse(a);t.each(e.ads,function(a,e){t("#"+e.element_id).html(e.code)})}})}}}(jQuery);jQuery(document).ready(function(){bzx.init()});

</script>

<script>
 var disqus_shortname = 'nehandatv';
            (function () {
                var s = document.createElement('script'); s.async = true;
                s.type = 'text/javascript';
                s.src = '//' + disqus_shortname + '.disqus.com/count.js';
                (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
            }());
		//<script>

		(function(){
		var disqus_shortname = 'nehandatv';


		function beforeLoad(e,$wrapper, $this) {

             var $prevEl = jQuery('#disqus_thread');

             if($prevEl.length === 0) {
                 return;
             }

            $prevEl.removeAttr('id');

            $prevEl.addClass('disqus_thread_prev');
		}

		function appendDisqusScript(e,$wrapper, res) {

		if( typeof DISQUS === 'object' && DISQUS.reset ) {

        var info = res && res.info ? res.info : {};


		jQuery(".disqus_thread_prev").each(function(){

		    var $prevEl = jQuery(this),
		        $respond = $prevEl.closest('.comments-template'),
		     $link = $respond.parent().find('.ajaxified-comments-container');

            $link.show();
			$link.children().show();

			$respond.remove();

		});

		DISQUS.reset({
		reload: true,
		config: function () {
		this.page.identifier = info.post_id;
		this.page.url = info.permalink;
		this.page.title = info.title;
		}
		});



		} else {

		var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
		dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
		}

		};

		        appendDisqusScript();
		
		})();
		

</script>

<script src='https://stats.wp.com/e-202211.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.8-a.7',blog:'15121527',post:'60351',tz:'2',srv:'nehandatv.com'} ]);
	_stq.push([ 'clickTrackerInit', '15121527', '60351' ]);
</script>
</body>
</html>

