 <!DOCTYPE html>
<!--[if IE 8]>
	<html class="ie ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>
	<html class="ie ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!-->
<html lang="en-US"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://nehandatv.com/xmlrpc.php" />
<title>Full address by Nelson Chamisa: Zimbabwe 40th Independence Day - Nehanda TV</title>

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Full address by Nelson Chamisa: Zimbabwe 40th Independence Day - Nehanda TV" />
<meta property="og:description" content="Watch the full address by opposition MDC Alliance leader Nelson Chamisa on the occasion of Zimbabwe&#039;s 40th Independence Day Celebrations." />
<meta property="og:url" content="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/" />
<meta property="og:site_name" content="Nehanda TV" />
<meta property="article:publisher" content="https://www.facebook.com/NehandaTV" />
<meta property="article:tag" content="Nelson Chamisa" />
<meta property="article:tag" content="zimbabwe independence" />
<meta property="article:tag" content="Zimbabwe Independence Day Celebrations" />
<meta property="article:section" content="Politics" />
<meta property="article:published_time" content="2020-04-18T13:50:35+00:00" />
<meta property="article:modified_time" content="2020-04-18T14:03:55+00:00" />
<meta property="og:updated_time" content="2020-04-18T14:03:55+00:00" />
<meta property="og:image" content="https://nehandatv.com/wp-content/uploads/2020/04/full-address-by-nelson-chamisa-z.jpg" />
<meta property="og:image:secure_url" content="https://nehandatv.com/wp-content/uploads/2020/04/full-address-by-nelson-chamisa-z.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Watch the full address by opposition MDC Alliance leader Nelson Chamisa on the occasion of Zimbabwe&#039;s 40th Independence Day Celebrations." />
<meta name="twitter:title" content="Full address by Nelson Chamisa: Zimbabwe 40th Independence Day - Nehanda TV" />
<meta name="twitter:site" content="@nehandatv" />
<meta name="twitter:image" content="https://nehandatv.com/wp-content/uploads/2020/04/full-address-by-nelson-chamisa-z.jpg" />
<meta name="twitter:creator" content="@nehandatv" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://nehandatv.com/#website","url":"https://nehandatv.com/","name":"Nehanda TV","inLanguage":"en-US","description":"Videos for Zimbabwe by Zimbabweans","potentialAction":[{"@type":"SearchAction","target":"https://nehandatv.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/#primaryimage","inLanguage":"en-US","url":"https://nehandatv.com/wp-content/uploads/2020/04/full-address-by-nelson-chamisa-z.jpg","width":1280,"height":720},{"@type":"WebPage","@id":"https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/#webpage","url":"https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/","name":"Full address by Nelson Chamisa: Zimbabwe 40th Independence Day - Nehanda TV","isPartOf":{"@id":"https://nehandatv.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/#primaryimage"},"datePublished":"2020-04-18T13:50:35+00:00","dateModified":"2020-04-18T14:03:55+00:00","author":{"@id":"https://nehandatv.com/#/schema/person/3261dbafeb321180a4ebd525fb502eed"},"potentialAction":[{"@type":"ReadAction","target":["https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/"]}]},{"@type":["Person"],"@id":"https://nehandatv.com/#/schema/person/3261dbafeb321180a4ebd525fb502eed","name":"Nehanda TV","image":{"@type":"ImageObject","@id":"https://nehandatv.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fe7dcd77bb491c8d45308d6b5a0db920?s=96&d=mm&r=g","caption":"Nehanda TV"},"sameAs":["https://twitter.com/nehandatv"]}]}</script>

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Feed" href="https://nehandatv.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Comments Feed" href="https://nehandatv.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nehanda TV &raquo; Full address by Nelson Chamisa: Zimbabwe 40th Independence Day Comments Feed" href="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nehandatv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://nehandatv.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='share-this-share-buttons-sticky-css' href='https://nehandatv.com/wp-content/plugins/sharethis-share-buttons/css/mu-style.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='better-framework-main-fonts-css' href='https://fonts.googleapis.com/css?family=Lato:400,700%7CRoboto:400,500,700,400italic' type='text/css' media='all' />
<script type='text/javascript' src='https://nehandatv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://nehandatv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#property=59bef23fd022ae0011cd882a&#038;product=inline-wp-share-buttons-wp'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://nehandatv.com/wp-content/plugins/better-adsmanager/includes/libs/better-framework/assets/js/html5shiv.min.js?ver=3.10.16'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='https://nehandatv.com/wp-content/plugins/better-adsmanager/includes/libs/better-framework/assets/js/respond.min.js?ver=3.10.16'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://nehandatv.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nehandatv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nehandatv.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4" />
<link rel='shortlink' href='https://nehandatv.com/?p=52762' />
<link rel="alternate" type="application/json+oembed" href="https://nehandatv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnehandatv.com%2F2020%2F04%2F18%2Ffull-address-by-nelson-chamisa-zimbabwe-40th-independence-day%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nehandatv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnehandatv.com%2F2020%2F04%2F18%2Ffull-address-by-nelson-chamisa-zimbabwe-40th-independence-day%2F&#038;format=xml" />
<script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});
_taboola.push({additional_data:{sdkd:{
    "os" : "Wordpress",
    "osv" : "5.4",
    "sdkt" : "Taboola Wordpress Plugin",
    "sdkv" : "1.0.9"
}}});
!function (e, f, u) {
	e.async = 1;
  e.src = u;
  f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/gandaco-nehandatv/loader.js');
</script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9836702761589703",
          enable_page_level_ads: true,
    overlays: {bottom: true}
     });
</script>
<script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=59bef23fd022ae0011cd882a&product=inline-share-buttons-wp"></script>
<meta name="google-site-verification" content="s5gP_JiEVy8xPHeYem8fJMNLKiyx542BXp6nsYpzqW0" />
<link rel="manifest" href="/manifest.json" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(function() {
    OneSignal.init({
      appId: "79c8c945-5a74-4e3e-a447-421f8b89a839",
    });
  });
</script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gandaco-nehandatv/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script> <meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://nehandatv.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '79c8c945-5a74-4e3e-a447-421f8b89a839';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://nehandatv.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "Organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/nehandatv.com\/wp-content\/uploads\/2019\/04\/NehandaTVNewLogo-524x180.png"
    },
    "url": "https:\/\/nehandatv.com\/",
    "name": "Nehanda TV",
    "description": "Videos for Zimbabwe by Zimbabweans"
}</script>
<script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "Nehanda TV",
    "alternateName": "Videos for Zimbabwe by Zimbabweans",
    "url": "https:\/\/nehandatv.com\/"
}</script>
<script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Full address by Nelson Chamisa: Zimbabwe 40th Independence Day",
    "description": "Watch the full address by opposition MDC Alliance leader Nelson Chamisa on the occasion of Zimbabwe's 40th Independence Day Celebrations.",
    "datePublished": "2020-04-18",
    "dateModified": "2020-04-18",
    "author": {
        "@type": "Person",
        "@id": "#person-NehandaTV",
        "name": "Nehanda TV"
    },
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/full-address-by-nelson-chamisa-z.jpg",
        "width": 1280,
        "height": 720
    },
    "interactionStatistic": [
        {
            "@type": "InteractionCounter",
            "interactionType": "http:\/\/schema.org\/CommentAction",
            "userInteractionCount": "17"
        }
    ],
    "publisher": {
        "@id": "#organization"
    },
    "mainEntityOfPage": "https:\/\/nehandatv.com\/2020\/04\/18\/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day\/"
}</script>
<link rel='stylesheet' id='bf-minifed-css-1' href='https://nehandatv.com/wp-content/bs-booster-cache/50b0c720d88e828c035816bf71c1e401.css' type='text/css' media='all' />
<link rel='stylesheet' id='7.6.2-1587149933' href='https://nehandatv.com/wp-content/bs-booster-cache/352e71e20dfcbcc983473ff392773966.css' type='text/css' media='all' />
<link rel="icon" href="https://nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://nehandatv.com/wp-content/uploads/2019/05/cropped-nehandaTV-site-favicon-512x512-270x270.jpg" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> </head>
<body class="post-template-default single single-post postid-52762 single-format-standard bs-theme bs-publisher bs-publisher-clean-magazine active-light-box active-top-line ltr close-rh page-layout-2-col-right full-width main-menu-sticky-smart active-ajax-search single-cat-7 single-cat-11 single-prim-cat-13 single-cat-13  bs-hide-ha wpb-js-composer js-comp-ver-6.1 vc_responsive bs-ll-a" dir="ltr">
<div class="off-canvas-overlay"></div>
<div class="off-canvas-container left skin-white">
<div class="off-canvas-inner">
<span class="canvas-close"><i></i></span>
<div class="off-canvas-header">
<div class="site-description">Videos for Zimbabwe by Zimbabweans</div>
</div>
<div class="off-canvas-search">
<form role="search" method="get" action="https://nehandatv.com">
<input type="text" name="s" value="" placeholder="Search...">
<i class="fa fa-search"></i>
</form>
</div>
<div class="off-canvas-menu">
<div class="off-canvas-menu-fallback"></div>
</div>
<div class="off_canvas_footer">
<div class="off_canvas_footer-info entry-content">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button colored in-4-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-title"> Likes </span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-title"> Subscribers </span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item rss"><a href="https://nehandatv.com/feed/rss/" target="_blank"> <i class="item-icon bsfi-rss"></i><span class="item-title"> Subscribe </span> </a> </li> </ul>
</div>
</div>
</div>
</div>
</div>
<div class="main-wrap content-main-wrap">
<header id="header" class="site-header header-style-2 full-width" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<section class="topbar topbar-style-1 hidden-xs hidden-xs">
<div class="content-wrap">
<div class="container">
<div class="topbar-inner clearfix">
<div class="section-links">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button not-colored in-4-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-title"> Likes </span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item google"><a href="https://plus.google.com/116030018206526131828" target="_blank"> <i class="item-icon bsfi-google"></i><span class="item-title"> Followers </span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-title"> Subscribers </span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-title"> Followers </span> </a> </li> </ul>
</div>
<a class="topbar-sign-in behind-social" data-toggle="modal" data-target="#bsLoginModal">
<i class="fa fa-user-circle"></i> Sign in </a>
<div class="modal sign-in-modal fade" id="bsLoginModal" tabindex="-1" role="dialog" style="display: none">
<div class="modal-dialog" role="document">
<div class="modal-content">
<span class="close-modal" data-dismiss="modal" aria-label="Close"><i class="fa fa-close"></i></span>
<div class="modal-body">
<div id="form_81018_" class="bs-shortcode bs-login-shortcode ">
<div class="bs-login bs-type-login" style="display:none">
<div class="bs-login-panel bs-login-sign-panel bs-current-login-panel">
<form name="loginform" action="https://nehandatv.com/wp-login.php" method="post">
<div class="login-header">
<span class="login-icon fa fa-user-circle main-color"></span>
<p>Welcome, Login to your account.</p>
</div>
<div class="login-field login-username">
<input type="text" name="log" id="form_81018_user_login" class="input" value="" size="20" placeholder="Username or Email..." required />
</div>
<div class="login-field login-password">
<input type="password" name="pwd" id="form_81018_user_pass" class="input" value="" size="20" placeholder="Password..." required />
</div>
<div class="login-field">
<a href="https://nehandatv.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fnehandatv.com%2F2020%2F04%2F18%2Ffull-address-by-nelson-chamisa-zimbabwe-40th-independence-day%2F" class="go-reset-panel">Forget password?</a>
<span class="login-remember">
<input class="remember-checkbox" name="rememberme" type="checkbox" id="form_81018_rememberme" value="forever" />
<label class="remember-label">Remember me</label>
</span>
</div>
<div class="login-field login-submit">
<input type="submit" name="wp-submit" class="button-primary login-btn" value="Log In" />
<input type="hidden" name="redirect_to" value="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/" />
</div>
</form>
</div>
<div class="bs-login-panel bs-login-reset-panel">
<span class="go-login-panel"><i class="fa fa-angle-left"></i> Sign in</span>
<div class="bs-login-reset-panel-inner">
<div class="login-header">
<span class="login-icon fa fa-support"></span>
<p>Recover your password.</p>
<p>A password will be e-mailed to you.</p>
</div>
<form name="lostpasswordform" id="form_81018_lostpasswordform" action="https://nehandatv.com/wp-login.php?action=lostpassword" method="post">
<div class="login-field reset-username">
<input type="text" name="user_login" class="input" value="" placeholder="Username or Email..." required />
</div>
<div class="login-field reset-submit">
<input type="hidden" name="redirect_to" value="" />
<input type="submit" name="wp-submit" class="login-btn" value="Send My Password" />
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="section-menu">
<div id="menu-top" class="menu top-menu-wrapper" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<nav class="top-menu-container">
<ul id="top-navigation" class="top-menu menu clearfix bsm-pure">
<li id="topbar-date" class="menu-item menu-item-date">
<span class="topbar-date">Saturday, April 18, 2020</span>
</li>
<li id="menu-item-12172" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-12172"><a href="https://nehandatv.com/about-us/">About Us</a></li>
<li id="menu-item-15822" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-15822"><a href="https://nehandatv.com/contact-us-2/">Contact us</a></li>
<li id="menu-item-7934" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-7934"><a href="https://nehandatv.com/advertising/">Advertising</a></li>
<li id="menu-item-38970" class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-38970"><a href="https://nehandatv.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-22542" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22542"><a href="http://tellyafrica.com/">Telly Africa</a></li>
<li id="menu-item-22541" class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22541"><a href="http://nehandaradio.com/">Nehanda Radio</a></li>
</ul>
</nav>
</div>
</div>
</div>
</div>
</div>
</section>
<div class="header-inner">
<div class="content-wrap">
<div class="container">
<div class="row">
<div class="row-height">
<div class="logo-col col-xs-4">
<div class="col-inside">
<div id="site-branding" class="site-branding">
<p id="site-title" class="logo h1 img-logo">
<a href="https://nehandatv.com/" itemprop="url" rel="home">
<img id="site-logo" src="https://nehandatv.com/wp-content/uploads/2019/04/NehandaTVNewLogo-524x180.png" alt="Publisher" data-bsrjs="https://nehandatv.com/wp-content/uploads/2019/04/NehandaTVNewLogo-524x180.png" />
<span class="site-title">Publisher - Videos for Zimbabwe by Zimbabweans</span>
</a>
</p>
</div>
</div>
</div>
<div class="sidebar-col col-xs-8">
<div class="col-inside">
<aside id="sidebar" class="sidebar" role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div class="qfj qfj-clearfix qfj-pubadban qfj-show-desktop qfj-show-tablet-portrait qfj-show-tablet-landscape qfj-show-phone qfj-loc-header_aside_logo qfj-align-center qfj-column-1"><div id="qfj-28264-775338276" class="qfj-container qfj-type-custom_code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="28264" data-type="custom_code"><ins class='dcmads' style='display:inline-block;width:728px;height:90px' data-dcm-placement='N192003.2121902NEHANDARADIO/B8808879.142414288' data-dcm-rendering-mode='iframe' data-dcm-https-only data-dcm-resettable-device-id='' data-dcm-app-id=''>
<script src='https://www.googletagservices.com/dcm/dcmads.js'></script>
</ins></div></div> </aside>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="menu-main" class="menu main-menu-wrapper show-search-item show-off-canvas menu-actions-btn-width-2" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="main-menu-inner">
<div class="content-wrap">
<div class="container">
<nav class="main-menu-container">
<ul id="main-navigation" class="main-menu menu bsm-pure clearfix">
<li id="menu-item-1551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-1551"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
<li id="menu-item-1552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-1552"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li id="menu-item-1563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-5 better-anim-fade menu-item-1563"><a href="https://nehandatv.com/category/crime/">Crime</a></li>
<li id="menu-item-10925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-10925"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
<li id="menu-item-1557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-8 better-anim-fade menu-item-1557"><a href="https://nehandatv.com/category/interviews/">Interviews</a></li>
<li id="menu-item-1554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-10 better-anim-fade menu-item-1554"><a href="https://nehandatv.com/category/music/">Music</a></li>
<li id="menu-item-1555" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-11 better-anim-fade menu-item-1555"><a href="https://nehandatv.com/category/news/">News</a></li>
<li id="menu-item-1556" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-13 better-anim-fade menu-item-1556"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li id="menu-item-10924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-15 better-anim-fade menu-item-10924"><a href="https://nehandatv.com/category/sports/">Sports</a></li>
</ul>
<div class="menu-action-buttons width-2">
<div class="off-canvas-menu-icon-container off-icon-left">
<div class="off-canvas-menu-icon">
<div class="off-canvas-menu-icon-el"></div>
</div>
</div>
<div class="search-container close">
<span class="search-handler"><i class="fa fa-search"></i></span>
<div class="search-box clearfix">
<form role="search" method="get" class="search-form clearfix" action="https://nehandatv.com">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" autocomplete="off">
<input type="submit" class="search-submit" value="Search">
</form>
</div>
</div>
</div>
</nav>
</div>
</div>
</div>
</div>
</header>
<div class="rh-header clearfix light deferred-block-exclude">
<div class="rh-container clearfix">
<div class="menu-container close">
<span class="menu-handler"><span class="lines"></span></span>
</div>
<div class="logo-container rh-img-logo">
<a href="https://nehandatv.com/" itemprop="url" rel="home">
<img src="https://nehandatv.com/wp-content/uploads/2019/05/NehandaTVlogo-300x45.png" alt="Nehanda TV" data-bsrjs="https://nehandatv.com/wp-content/uploads/2019/05/NehandaTVlogo2.png" /> </a>
</div>
</div>
</div>
<div class="container adcontainer"><div class="qfj qfj-clearfix qfj-after-header qfj-pubadban qfj-show-desktop qfj-show-tablet-portrait qfj-show-tablet-landscape qfj-show-phone qfj-loc-header_after qfj-align-center qfj-column-1"><div id="qfj-27187-315770603" class="qfj-container qfj-type-code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="27187" data-type="code"><div id="qfj-27187-315770603-place"></div><script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('qfj-27187-315770603');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('qfj-27187-315770603-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('qfj-27187-315770603-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('qfj-27187-315770603-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:' + betterads_el_width[0] + 'px;height:' + betterads_el_width[1] + 'px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width < 768 ) {          document.getElementById('qfj-27187-315770603-place').innerHTML = '<ins class="adsbygoogle" style="display:inline-block;width:640px;height:165px"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="3433033089" ></ins>';          (adsbygoogle = window.adsbygoogle || []).push({});         }</script></div></div></div><div class="content-wrap">
<main id="content" class="content-container">
<div class="container layout-2-col layout-2-col-1 layout-right-sidebar post-template-10">
<div class="row main-section">
<div class="col-sm-8 content-column">
<div class="single-container">
<article id="post-52762" class="post-52762 post type-post status-publish format-standard has-post-thumbnail  category-featured category-news category-politics tag-nelson-chamisa tag-zimbabwe-independence tag-zimbabwe-independence-day-celebrations single-post-content">
<div class="single-featured"></div>
<div class="post-header-inner">
<div class="post-header-title">
<div class="term-badges floated"><span class="term-badge term-13"><a href="https://nehandatv.com/category/politics/">Politics</a></span><span class="term-badge term-7"><a href="https://nehandatv.com/category/featured/">Featured</a></span><span class="term-badge term-11"><a href="https://nehandatv.com/category/news/">News</a></span></div> <h1 class="single-post-title">
<span class="post-title" itemprop="headline">Full address by Nelson Chamisa: Zimbabwe 40th Independence Day</span>
</h1>
<div class="post-meta single-post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-18T16:03:55+02:00">Last updated <b>Apr 18, 2020</b></time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52762"><i class="bf-icon  bsfi-fire-4"></i> 6,742</span><a href="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/#disqus_thread" title="Leave a comment on: &ldquo;Full address by Nelson Chamisa: Zimbabwe 40th Independence Day&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a></div>
</div>
</div>
<div class="entry-content clearfix single-post-content">
<div style="margin-top: 0px; margin-bottom: 0px;" class="sharethis-inline-share-buttons"></div><p><strong>Watch the full address by opposition MDC Alliance leader Nelson Chamisa on the occasion of Zimbabwe&#8217;s 40th Independence Day Celebrations.</strong></p>
<p><iframe title="President Nelson Chamisa, Zimbabwe Independence @40 Address" width="1170" height="658" src="https://www.youtube.com/embed/ZjevlsRQOZM?wmode=transparent&amp;rel=0&amp;feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<span id='tbmarker'></span><script type='text/javascript'>function insertAfter(e,t){t.parentNode.insertBefore(e,t.nextSibling)}function getElementByXPath(e,t){if(!t)t=document;if(t.evaluate)return t.evaluate(e,document,null,9,null).singleNodeValue;while(e.charAt(0)=="/")e=e.substr(1);var n=t;var r=e.split("/");for(var i=0;i<r.length;i++){var a=r[i].split(/(\w*)\[(\d*)\]/gi).filter(function(e){return!(e==""||e.match(/\s/gi))},this);var l=a[0];var o=a[1]?a[1]-1:0;if(i<r.length-1)n=n.getElementsByTagName(l)[o];else return n.getElementsByTagName(l)[o]}}if(!Array.prototype.filter){Array.prototype.filter=function(e){var t=this.length>>>0;if(typeof e!="function"){throw new TypeError}var n=[];var r=arguments[1];for(var i=0;i<t;i++){if(i in this){var a=this[i];if(e.call(r,a,i,this)){n.push(a)}}}return n}}function injectWidgetByXpath(e){var t=getElementByXPath(e);if(t==null){t=document.getElementById("tbdefault")}innerInject(t)}function injectWidgetByMarker(e){var t=document.getElementById(e);innerInject(t.parentNode)}function innerInject(e){var t=document.createElement("span");var n=document.createElement("script");var r="if JS crashes here, the first innerHTML value should be enclosed with single quotes instead of double, go to the minified version and change it";t.innerHTML="<div id='taboola-below-article'></div>";n.innerHTML="window._taboola = window._taboola || [];_taboola.push({mode:'thumbnails-b', container:'taboola-below-article', placement:'below-article', target_type: 'mix'});";insertAfter(t,e);insertAfter(n,t)}injectWidgetByMarker('tbmarker');</script><div class="qfj qfj-clearfix qfj-post-bottom qfj-float-center qfj-align-center qfj-column-1"><div id="qfj-30798-762471716" class="qfj-container qfj-type-code " itemscope="" itemtype="https://schema.org/WPAdBlock" data-adid="30798" data-type="code"><div id="qfj-30798-762471716-place"></div><script type="text/javascript">var betterads_screen_width = document.body.clientWidth;betterads_el = document.getElementById('qfj-30798-762471716');             if (betterads_el.getBoundingClientRect().width) {     betterads_el_width_raw = betterads_el_width = betterads_el.getBoundingClientRect().width;    } else {     betterads_el_width_raw = betterads_el_width = betterads_el.offsetWidth;    }        var size = ["125", "125"];    if ( betterads_el_width >= 728 )      betterads_el_width = ["728", "90"];    else if ( betterads_el_width >= 468 )     betterads_el_width = ["468", "60"];    else if ( betterads_el_width >= 336 )     betterads_el_width = ["336", "280"];    else if ( betterads_el_width >= 300 )     betterads_el_width = ["300", "250"];    else if ( betterads_el_width >= 250 )     betterads_el_width = ["250", "250"];    else if ( betterads_el_width >= 200 )     betterads_el_width = ["200", "200"];    else if ( betterads_el_width >= 180 )     betterads_el_width = ["180", "150"]; if ( betterads_screen_width >= 1140 ) { document.getElementById('qfj-30798-762471716-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 1019  && betterads_screen_width < 1140 ) { document.getElementById('qfj-30798-762471716-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width >= 768  && betterads_screen_width < 1019 ) { document.getElementById('qfj-30798-762471716-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}else if ( betterads_screen_width < 768 ) { document.getElementById('qfj-30798-762471716-place').innerHTML = '<ins class="adsbygoogle" style="display:block;"  data-ad-client="ca-pub-9836702761589703"  data-ad-slot="2408623768"  data-full-width-responsive="true"  data-ad-format="auto" ></ins>';         (adsbygoogle = window.adsbygoogle || []).push({});}</script></div></div> </div>
<div class="entry-terms post-tags clearfix ">
<span class="terms-label"><i class="fa fa-tags"></i></span>
<a href="https://nehandatv.com/tag/nelson-chamisa/" rel="tag">Nelson Chamisa</a><a href="https://nehandatv.com/tag/zimbabwe-independence/" rel="tag">zimbabwe independence</a><a href="https://nehandatv.com/tag/zimbabwe-independence-day-celebrations/" rel="tag">Zimbabwe Independence Day Celebrations</a> </div>
</article>
<section class="next-prev-post clearfix">
<div class="prev-post">
<p class="pre-title heading-typo"><i class="fa fa-arrow-left"></i> Prev Post </p>
<p class="title heading-typo"><a href="https://nehandatv.com/2020/04/17/skin-bleachers-madam-boss-hilarious-dontrushchallenge/" rel="prev">Skin Bleachers: Madam Boss: Hilarious #Don’tRushChallenge</a></p>
</div>
<div class="next-post">
<p class="pre-title heading-typo">Next Post <i class="fa fa-arrow-right"></i></p>
<p class="title heading-typo"><a href="https://nehandatv.com/2020/04/18/kuda-chamisa-on-first-lady-auxillia-mnangagwas-love-for-photos/" rel="next">Kuda Chamisa on First Lady Auxillia Mnangagwa&#8217;s love for PHOTOS</a></p>
</div>
</section>
</div>
<div class="post-related">
<div class="section-heading sh-t1 sh-s1 multi-tab">
<a href="#relatedposts_2058550175_1" class="main-link active" data-toggle="tab">
<span class="h-text related-posts-heading">You might also like</span>
</a>
<a href="#relatedposts_2058550175_2" class="other-link" data-toggle="tab" data-deferred-event="shown.bs.tab" data-deferred-init="relatedposts_2058550175_2">
<span class="h-text related-posts-heading">More from author</span>
</a>
</div>
<div class="tab-content">
<div class="tab-pane bs-tab-anim bs-tab-animated active" id="relatedposts_2058550175_1">
<div class="bs-pagination-wrapper main-term-none next_prev ">
<div class="listing listing-thumbnail listing-tb-2 clearfix  scolumns-3 simple-grid include-last-mobile">
<div class="post-52547 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-2 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<div class="term-badges floated"><span class="term-badge term-13"><a href="https://nehandatv.com/category/politics/">Politics</a></span></div> <a title="Chamisa is the Obama of our time, he is loved by many &#8211; Thomas Machinga (VIDEO)" data-src="https://nehandatv.com/wp-content/uploads/2020/04/chamisa-is-the-obama-of-our-time-210x136.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;chamisa-is-the-obama-of-our-time-86x64.jpg&quot;,&quot;210&quot;:&quot;chamisa-is-the-obama-of-our-time-210x136.jpg&quot;,&quot;279&quot;:&quot;chamisa-is-the-obama-of-our-time-279x220.jpg&quot;,&quot;357&quot;:&quot;chamisa-is-the-obama-of-our-time-357x210.jpg&quot;,&quot;750&quot;:&quot;chamisa-is-the-obama-of-our-time-750x430.jpg&quot;,&quot;1280&quot;:&quot;chamisa-is-the-obama-of-our-time.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/05/chamisa-is-the-obama-of-our-time-he-is-loved-by-many-thomas-machinga-video/"></a>
</div>
<p class="title"> <a class="post-url" href="https://nehandatv.com/2020/04/05/chamisa-is-the-obama-of-our-time-he-is-loved-by-many-thomas-machinga-video/" title="Chamisa is the Obama of our time, he is loved by many &#8211; Thomas Machinga (VIDEO)">
<span class="post-title">
Chamisa is the Obama of our time, he is loved by many &#8211; Thomas Machinga (VIDEO) </span>
</a>
</p></div>
</div >
<div class="post-52491 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-2 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<div class="term-badges floated"><span class="term-badge term-13"><a href="https://nehandatv.com/category/politics/">Politics</a></span></div> <a title="&#8216;Chamisa&#8217;s prophecy and way forward coming to pass&#8217; &#8211; JCTV Zimbabwe" data-src="https://nehandatv.com/wp-content/uploads/2020/04/chamisas-prophecy-and-way-forwar-210x136.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;chamisas-prophecy-and-way-forwar-86x64.jpg&quot;,&quot;210&quot;:&quot;chamisas-prophecy-and-way-forwar-210x136.jpg&quot;,&quot;279&quot;:&quot;chamisas-prophecy-and-way-forwar-279x220.jpg&quot;,&quot;357&quot;:&quot;chamisas-prophecy-and-way-forwar-357x210.jpg&quot;,&quot;750&quot;:&quot;chamisas-prophecy-and-way-forwar-750x430.jpg&quot;,&quot;1280&quot;:&quot;chamisas-prophecy-and-way-forwar.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/02/chamisas-prophecy-and-way-forward-coming-to-pass-jctv-zimbabwe/"></a>
</div>
<p class="title"> <a class="post-url" href="https://nehandatv.com/2020/04/02/chamisas-prophecy-and-way-forward-coming-to-pass-jctv-zimbabwe/" title="&#8216;Chamisa&#8217;s prophecy and way forward coming to pass&#8217; &#8211; JCTV Zimbabwe">
<span class="post-title">
&#8216;Chamisa&#8217;s prophecy and way forward coming to pass&#8217; &#8211; JCTV&hellip; </span>
</a>
</p></div>
</div >
<div class="post-51950 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-2 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<div class="term-badges floated"><span class="term-badge term-13"><a href="https://nehandatv.com/category/politics/">Politics</a></span></div> <a title="Chamisa mocks Mnangagwa over mortuary joke&#8230; tells him &#8216;your days are numbered&#8217;" data-src="https://nehandatv.com/wp-content/uploads/2020/03/chamisa-mocks-mnangagwa-over-mor-210x136.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;chamisa-mocks-mnangagwa-over-mor-86x64.jpg&quot;,&quot;210&quot;:&quot;chamisa-mocks-mnangagwa-over-mor-210x136.jpg&quot;,&quot;279&quot;:&quot;chamisa-mocks-mnangagwa-over-mor-279x220.jpg&quot;,&quot;357&quot;:&quot;chamisa-mocks-mnangagwa-over-mor-357x210.jpg&quot;,&quot;750&quot;:&quot;chamisa-mocks-mnangagwa-over-mor-750x430.jpg&quot;,&quot;1280&quot;:&quot;chamisa-mocks-mnangagwa-over-mor.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/03/13/chamisa-mocks-mnangagwa-over-mortuary-joke-his-days-are-numbered/"></a>
</div>
 <p class="title"> <a class="post-url" href="https://nehandatv.com/2020/03/13/chamisa-mocks-mnangagwa-over-mortuary-joke-his-days-are-numbered/" title="Chamisa mocks Mnangagwa over mortuary joke&#8230; tells him &#8216;your days are numbered&#8217;">
<span class="post-title">
Chamisa mocks Mnangagwa over mortuary joke&#8230; tells him &#8216;your days are&hellip; </span>
</a>
</p></div>
</div >
<div class="post-51412 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-2 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<div class="term-badges floated"><span class="term-badge term-13"><a href="https://nehandatv.com/category/politics/">Politics</a></span></div> <a title="Nelson Chamisa vows to lead mass protests in Zimbabwe &#8211; VIDEO" data-src="https://nehandatv.com/wp-content/uploads/2020/02/nelson-chamisa-vows-to-lead-mass-210x136.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/02\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;nelson-chamisa-vows-to-lead-mass-86x64.jpg&quot;,&quot;210&quot;:&quot;nelson-chamisa-vows-to-lead-mass-210x136.jpg&quot;,&quot;279&quot;:&quot;nelson-chamisa-vows-to-lead-mass-279x220.jpg&quot;,&quot;357&quot;:&quot;nelson-chamisa-vows-to-lead-mass-357x210.jpg&quot;,&quot;750&quot;:&quot;nelson-chamisa-vows-to-lead-mass-750x430.jpg&quot;,&quot;1280&quot;:&quot;nelson-chamisa-vows-to-lead-mass.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/02/20/nelson-chamisa-vows-to-lead-mass-protests-in-zimbabwe-video/"></a>
</div>
<p class="title"> <a class="post-url" href="https://nehandatv.com/2020/02/20/nelson-chamisa-vows-to-lead-mass-protests-in-zimbabwe-video/" title="Nelson Chamisa vows to lead mass protests in Zimbabwe &#8211; VIDEO">
<span class="post-title">
Nelson Chamisa vows to lead mass protests in Zimbabwe &#8211; VIDEO </span>
</a>
</p></div>
</div >
</div>
</div><div class="bs-pagination bs-ajax-pagination next_prev main-term-none clearfix">
<script>var bs_ajax_paginate_765203106 = '{"query":{"paginate":"next_prev","count":4,"post_type":"post","posts_per_page":4,"post__not_in":[52762],"ignore_sticky_posts":1,"tag__in":[2634,1121,10411],"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::fetch_related_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"6d4fc6c"}';</script> <a class="btn-bs-pagination prev disabled" rel="prev" data-id="765203106" title="Previous">
<i class="fa fa-angle-left" aria-hidden="true"></i> Prev </a>
<a rel="next" class="btn-bs-pagination next" data-id="765203106" title="Next">
Next <i class="fa fa-angle-right" aria-hidden="true"></i>
</a>
</div>
</div>
<div class="tab-pane bs-tab-anim bs-tab-animated bs-deferred-container" id="relatedposts_2058550175_2">
<div class="bs-pagination-wrapper main-term-none next_prev ">
<div class="bs-deferred-load-wrapper" id="bsd_relatedposts_2058550175_2">
<script>var bs_deferred_loading_bsd_relatedposts_2058550175_2 = '{"query":{"paginate":"next_prev","count":4,"author":1,"post_type":"post","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::fetch_other_related_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"1a54b4c"}';</script>
</div>
</div> </div>
</div>
</div>
<section id="comments-template-52762" class="comments-template comment-respond">
<div class="section-heading sh-t1 sh-s1"><span class="h-text">Comments</span>
</div>
<div id="comments" class="better-comments-area better-disqus-comments-area">
<div id="disqus_thread" data-post-id="52762"></div>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
</div>
</section>
</div>
<div class="col-sm-4 sidebar-column sidebar-column-primary">
<aside id="sidebar-primary-sidebar" class="sidebar" role="complementary" aria-label="Primary Sidebar Sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div id="bs-thumbnail-listing-1-2" class=" h-ni w-t primary-sidebar-widget widget widget_bs-thumbnail-listing-1"><div id="" class=" bs-listing bs-listing-listing-thumbnail-1 bs-listing-single-tab pagination-animate"> <p class="section-heading sh-t1 sh-s1 main-term-none">
<span class="h-text main-term-none main-link">
Recent Videos </span>
</p>
<div class="bs-pagination-wrapper main-term-none more_btn bs-slider-first-item">
<div class="listing listing-thumbnail listing-tb-1 clearfix columns-1">
<div class="post-52758 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-4">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a alt="Comedian Kuda Chamisa makes fun of First Lady Auxillia Mnangagwa&#039;s love for photos." title="Kuda Chamisa on First Lady Auxillia Mnangagwa&#8217;s love for PHOTOS" data-src="https://nehandatv.com/wp-content/uploads/2020/04/Comedian-Kuda-Chamisa-makes-fun-of-First-Lady-Auxillia-Mnangagwas-love-for-photos-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;Comedian-Kuda-Chamisa-makes-fun-of-First-Lady-Auxillia-Mnangagwas-love-for-photos-86x64.jpg&quot;,&quot;210&quot;:&quot;Comedian-Kuda-Chamisa-makes-fun-of-First-Lady-Auxillia-Mnangagwas-love-for-photos-210x136.jpg&quot;,&quot;720&quot;:&quot;Comedian-Kuda-Chamisa-makes-fun-of-First-Lady-Auxillia-Mnangagwas-love-for-photos.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/18/kuda-chamisa-on-first-lady-auxillia-mnangagwas-love-for-photos/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/18/kuda-chamisa-on-first-lady-auxillia-mnangagwas-love-for-photos/" class="post-url post-title">
Kuda Chamisa on First Lady Auxillia Mnangagwa&#8217;s love&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-18T15:53:32+02:00">Apr 18, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52758"><i class="bf-icon  bsfi-fire-4"></i>24,642</span><a href="https://nehandatv.com/2020/04/18/kuda-chamisa-on-first-lady-auxillia-mnangagwas-love-for-photos/#disqus_thread" title="Leave a comment on: &ldquo;Kuda Chamisa on First Lady Auxillia Mnangagwa&#8217;s love for PHOTOS&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52762 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Full address by Nelson Chamisa: Zimbabwe 40th Independence Day" data-src="https://nehandatv.com/wp-content/uploads/2020/04/full-address-by-nelson-chamisa-z-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;full-address-by-nelson-chamisa-z-86x64.jpg&quot;,&quot;210&quot;:&quot;full-address-by-nelson-chamisa-z-210x136.jpg&quot;,&quot;1280&quot;:&quot;full-address-by-nelson-chamisa-z.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/" class="post-url post-title">
Full address by Nelson Chamisa: Zimbabwe 40th Independence&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-18T15:50:35+02:00">Apr 18, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52762"><i class="bf-icon  bsfi-fire-4"></i>6,742</span><a href="https://nehandatv.com/2020/04/18/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day/#disqus_thread" title="Leave a comment on: &ldquo;Full address by Nelson Chamisa: Zimbabwe 40th Independence Day&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52751 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-4">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Skin Bleachers: Madam Boss: Hilarious #Don’tRushChallenge" data-src="https://nehandatv.com/wp-content/uploads/2020/04/Madam-Boss-dont-rush-challenge-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;Madam-Boss-dont-rush-challenge-86x64.jpg&quot;,&quot;210&quot;:&quot;Madam-Boss-dont-rush-challenge-210x136.jpg&quot;,&quot;745&quot;:&quot;Madam-Boss-dont-rush-challenge.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/17/skin-bleachers-madam-boss-hilarious-dontrushchallenge/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/17/skin-bleachers-madam-boss-hilarious-dontrushchallenge/" class="post-url post-title">
Skin Bleachers: Madam Boss: Hilarious #Don’tRushChallenge </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-17T18:22:41+02:00">Apr 17, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52751"><i class="bf-icon  bsfi-fire-4"></i>25,758</span><a href="https://nehandatv.com/2020/04/17/skin-bleachers-madam-boss-hilarious-dontrushchallenge/#disqus_thread" title="Leave a comment on: &ldquo;Skin Bleachers: Madam Boss: Hilarious #Don’tRushChallenge&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52747 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-10">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Roby Gee: Ndiwe feat Tytan (Official Audio)" data-src="https://nehandatv.com/wp-content/uploads/2020/04/roby-gee-ndiwe-feat-tytan-offici-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;roby-gee-ndiwe-feat-tytan-offici-86x64.jpg&quot;,&quot;210&quot;:&quot;roby-gee-ndiwe-feat-tytan-offici-210x136.jpg&quot;,&quot;480&quot;:&quot;roby-gee-ndiwe-feat-tytan-offici.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/17/roby-gee-ndiwe-feat-tytan-official-audio/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/17/roby-gee-ndiwe-feat-tytan-official-audio/" class="post-url post-title">
Roby Gee: Ndiwe feat Tytan (Official Audio) </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-17T17:41:36+02:00">Apr 17, 2020</time></span>
<span class="views post-meta-views rank-500" data-bpv-post="52747"><i class="bf-icon  bsfi-fire-1"></i>614</span><a href="https://nehandatv.com/2020/04/17/roby-gee-ndiwe-feat-tytan-official-audio/#disqus_thread" title="Leave a comment on: &ldquo;Roby Gee: Ndiwe feat Tytan (Official Audio)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52744 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-4">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Remote Ndeyani: This Lockdown &#8211; Bustop TV" data-src="https://nehandatv.com/wp-content/uploads/2020/04/remote-ndeyani-this-lockdown-bus-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;remote-ndeyani-this-lockdown-bus-86x64.jpg&quot;,&quot;210&quot;:&quot;remote-ndeyani-this-lockdown-bus-210x136.jpg&quot;,&quot;1280&quot;:&quot;remote-ndeyani-this-lockdown-bus.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/17/remote-ndeyani-this-lockdown-bustop-tv/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/17/remote-ndeyani-this-lockdown-bustop-tv/" class="post-url post-title">
Remote Ndeyani: This Lockdown &#8211; Bustop TV </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-17T14:40:53+02:00">Apr 17, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52744"><i class="bf-icon  bsfi-fire-4"></i>8,979</span><a href="https://nehandatv.com/2020/04/17/remote-ndeyani-this-lockdown-bustop-tv/#disqus_thread" title="Leave a comment on: &ldquo;Remote Ndeyani: This Lockdown &#8211; Bustop TV&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
</div>
</div><div class="bs-pagination bs-ajax-pagination more_btn main-term-none clearfix">
<script>var bs_ajax_paginate_1667067414 = '{"query":{"category":"","tag":"","taxonomy":"","post_ids":"","post_type":"","count":"5","order_by":"date","order":"DESC","time_filter":"","offset":"","style":"listing-thumbnail-1","cats-tags-condition":"and","cats-condition":"in","tags-condition":"in","featured_image":"0","ignore_sticky_posts":"1","author_ids":"","disable_duplicate":"0","ad-active":0,"paginate":"more_btn","pagination-show-label":"1","columns":1,"listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"0","share":"0","comment":"0","review":"1"}},"override-listing-settings":"0","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"bs_post_listing","view":"Publisher_Thumbnail_Listing_1_Shortcode","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"more_btn","pagination-show-label":"1","override-listing-settings":"0","listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"0","share":"0","comment":"0","review":"1"}},"columns":1,"ad-active":false,"_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"78f7492","data":{"vars":{"post-ranking-offset":5}}}';</script> <a rel="next" class="btn-bs-pagination" data-id="1667067414" title="Load More Posts">
<span class="loading" style="display: none;">
<i class="fa fa-refresh fa-spin fa-fw"></i>
</span>
<span class="loading" style="display: none;">
Loading ... </span>
<span class="loaded txt">
Load More Posts </span>
<span class="loaded icon">
<i class="fa fa-angle-down" aria-hidden="true"></i>
</span>
<span class="no-more" style="display: none;">
No More Posts
</span>
</a>
</div></div></div><div id="better-social-counter-2" class=" h-ni w-t primary-sidebar-widget widget widget_better-social-counter"><div class="section-heading sh-t1 sh-s1"><span class="h-text">Follow us for updates</span></div> <div class="  better-studio-shortcode bsc-clearfix better-social-counter style-box colored in-2-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href="https://www.facebook.com/NehandaTV" class="item-link" target="_blank"><i class="item-icon bsfi-facebook"></i> <span class="item-count"> 54,481</span> <span class="item-title"> Likes</span> </a> </li> <li class="social-item twitter"><a href="https://twitter.com/nehandatv" class="item-link" target="_blank"><i class="item-icon bsfi-twitter"></i> <span class="item-count"> 4,856</span> <span class="item-title"> Followers</span> </a> </li> <li class="social-item youtube"><a href="https://youtube.com/user/NehandaTV" class="item-link" target="_blank"><i class="item-icon bsfi-youtube"></i> <span class="item-count"> 18,600</span> <span class="item-title"> Subscribers</span> </a> </li> <li class="social-item instagram"><a href="https://instagram.com/nehandatv" class="item-link" target="_blank"><i class="item-icon bsfi-instagram"></i> <span class="item-count"> 1,624</span> <span class="item-title"> Followers</span> </a> </li> </ul>
</div>
</div><div id="bs-thumbnail-listing-1-3" class=" h-ni w-t primary-sidebar-widget widget widget_bs-thumbnail-listing-1"><div id="" class=" bs-listing bs-listing-listing-thumbnail-1 bs-listing-single-tab pagination-animate"> <p class="section-heading sh-t1 sh-s1 main-term-none">
<span class="h-text main-term-none main-link">
Most Commented this Month </span>
</p>
<div class="bs-pagination-wrapper main-term-none more_btn bs-slider-first-item">
<div class="listing listing-thumbnail listing-tb-1 clearfix columns-1">
<div class="post-52273 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-14">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Mambo Dhuterere attacks &#8216;guma guma&#8217; prophets amidst coronavirus &#8211; VIDEO" data-src="https://nehandatv.com/wp-content/uploads/2020/03/Mambo-Dhuterere-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;Mambo-Dhuterere-86x64.jpg&quot;,&quot;210&quot;:&quot;Mambo-Dhuterere-210x136.jpg&quot;,&quot;711&quot;:&quot;Mambo-Dhuterere.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/03/26/mambo-dhuterere-attacks-guma-guma-prophets-amidst-coronavirus-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/03/26/mambo-dhuterere-attacks-guma-guma-prophets-amidst-coronavirus-video/" class="post-url post-title">
Mambo Dhuterere attacks &#8216;guma guma&#8217; prophets&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-03-26T21:43:26+02:00">Mar 26, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52273"><i class="bf-icon  bsfi-fire-4"></i>46,656</span><a href="https://nehandatv.com/2020/03/26/mambo-dhuterere-attacks-guma-guma-prophets-amidst-coronavirus-video/#disqus_thread" title="Leave a comment on: &ldquo;Mambo Dhuterere attacks &#8216;guma guma&#8217; prophets amidst coronavirus &#8211; VIDEO&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52261 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-11">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="WATCH: Zimbabweans praying after being detained on arrival in Tanzania, they will be quarantined for 14 days at their own cost" data-src="https://nehandatv.com/wp-content/uploads/2020/03/watch-zimbabweans-praying-after-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/03\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;watch-zimbabweans-praying-after-86x64.jpg&quot;,&quot;210&quot;:&quot;watch-zimbabweans-praying-after-210x136.jpg&quot;,&quot;1280&quot;:&quot;watch-zimbabweans-praying-after.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/03/26/watch-zimbabweans-praying-after-detained-on-arrival-in-tanzania-they-will-be-quarantined-for-14-days-at-their-own-cost/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/03/26/watch-zimbabweans-praying-after-detained-on-arrival-in-tanzania-they-will-be-quarantined-for-14-days-at-their-own-cost/" class="post-url post-title">
WATCH: Zimbabweans praying after being detained on arrival&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-03-26T07:36:29+02:00">Mar 26, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52261"><i class="bf-icon  bsfi-fire-4"></i>68,413</span><a href="https://nehandatv.com/2020/03/26/watch-zimbabweans-praying-after-detained-on-arrival-in-tanzania-they-will-be-quarantined-for-14-days-at-their-own-cost/#disqus_thread" title="Leave a comment on: &ldquo;WATCH: Zimbabweans praying after being detained on arrival in Tanzania, they will be quarantined for 14 days at their own cost&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52547 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-13">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="Chamisa is the Obama of our time, he is loved by many &#8211; Thomas Machinga (VIDEO)" data-src="https://nehandatv.com/wp-content/uploads/2020/04/chamisa-is-the-obama-of-our-time-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;chamisa-is-the-obama-of-our-time-86x64.jpg&quot;,&quot;210&quot;:&quot;chamisa-is-the-obama-of-our-time-210x136.jpg&quot;,&quot;1280&quot;:&quot;chamisa-is-the-obama-of-our-time.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/05/chamisa-is-the-obama-of-our-time-he-is-loved-by-many-thomas-machinga-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/05/chamisa-is-the-obama-of-our-time-he-is-loved-by-many-thomas-machinga-video/" class="post-url post-title">
Chamisa is the Obama of our time, he is loved by many&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-05T11:05:48+02:00">Apr 5, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52547"><i class="bf-icon  bsfi-fire-4"></i>9,772</span><a href="https://nehandatv.com/2020/04/05/chamisa-is-the-obama-of-our-time-he-is-loved-by-many-thomas-machinga-video/#disqus_thread" title="Leave a comment on: &ldquo;Chamisa is the Obama of our time, he is loved by many &#8211; Thomas Machinga (VIDEO)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52631 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-7">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="&#8220;Uyu wengozi wekuchekeresa mukadzi uyu&#8221;  &#8211; Prophet Passion  Java hits back at Apostle Chiwenga (WATCH)" data-src="https://nehandatv.com/wp-content/uploads/2020/04/uyu-wengozi-wekuchekeresa-mukadz-86x64.jpg" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;uyu-wengozi-wekuchekeresa-mukadz-86x64.jpg&quot;,&quot;210&quot;:&quot;uyu-wengozi-wekuchekeresa-mukadz-210x136.jpg&quot;,&quot;480&quot;:&quot;uyu-wengozi-wekuchekeresa-mukadz.jpg&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/08/uyu-wengozi-wekuchekeresa-mukadzi-uyu-prophet-passion-java-hits-back-at-apostle-chiwenga-watch/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/08/uyu-wengozi-wekuchekeresa-mukadzi-uyu-prophet-passion-java-hits-back-at-apostle-chiwenga-watch/" class="post-url post-title">
&#8220;Uyu wengozi wekuchekeresa mukadzi uyu&#8221; &#8211;&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-08T13:06:57+02:00">Apr 8, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52631"><i class="bf-icon  bsfi-fire-4"></i>79,409</span><a href="https://nehandatv.com/2020/04/08/uyu-wengozi-wekuchekeresa-mukadzi-uyu-prophet-passion-java-hits-back-at-apostle-chiwenga-watch/#disqus_thread" title="Leave a comment on: &ldquo;&#8220;Uyu wengozi wekuchekeresa mukadzi uyu&#8221;  &#8211; Prophet Passion  Java hits back at Apostle Chiwenga (WATCH)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
<div class="post-52426 type-post format-standard has-post-thumbnail   listing-item listing-item-thumbnail listing-item-tb-1 main-term-14">
<div class="item-inner clearfix">
<div class="featured featured-type-featured-image">
<a title="&#8220;Ndokutora Shereni &#8230;..&#8221; 😌 &#8211; Prophet Passion Java speaks in tongues  (VIDEO)" data-src="https://nehandatv.com/wp-content/uploads/2020/04/Screen-Shot-2020-04-01-at-08.47.51-86x64.png" data-bs-srcset="{&quot;baseurl&quot;:&quot;https:\/\/nehandatv.com\/wp-content\/uploads\/2020\/04\/&quot;,&quot;sizes&quot;:{&quot;86&quot;:&quot;Screen-Shot-2020-04-01-at-08.47.51-86x64.png&quot;,&quot;210&quot;:&quot;Screen-Shot-2020-04-01-at-08.47.51-210x136.png&quot;,&quot;1286&quot;:&quot;Screen-Shot-2020-04-01-at-08.47.51.png&quot;}}" class="img-holder" href="https://nehandatv.com/2020/04/01/ndokutora-shereni-%f0%9f%98%8c-prophet-passion-java-speaks-in-tongues-video/"></a>
</div>
<p class="title"> <a href="https://nehandatv.com/2020/04/01/ndokutora-shereni-%f0%9f%98%8c-prophet-passion-java-speaks-in-tongues-video/" class="post-url post-title">
&#8220;Ndokutora Shereni &#8230;..&#8221; 😌 &#8211; Prophet&hellip; </a>
</p> <div class="post-meta">
<span class="time"><time class="post-published updated" datetime="2020-04-01T09:53:37+02:00">Apr 1, 2020</time></span>
<span class="views post-meta-views rank-3500" data-bpv-post="52426"><i class="bf-icon  bsfi-fire-4"></i>16,763</span><a href="https://nehandatv.com/2020/04/01/ndokutora-shereni-%f0%9f%98%8c-prophet-passion-java-speaks-in-tongues-video/#disqus_thread" title="Leave a comment on: &ldquo;&#8220;Ndokutora Shereni &#8230;..&#8221; 😌 &#8211; Prophet Passion Java speaks in tongues  (VIDEO)&rdquo;" class="comments"><i class="fa fa-comments-o"></i> </a> </div>
</div>
</div >
</div>
</div><div class="bs-pagination bs-ajax-pagination more_btn main-term-none clearfix">
<script>var bs_ajax_paginate_1762097763 = '{"query":{"category":"","tag":"","taxonomy":"","post_ids":"","post_type":"","count":"5","order_by":"comment_count","order":"DESC","time_filter":"month","offset":"","style":"listing-thumbnail-1","cats-tags-condition":"and","cats-condition":"in","tags-condition":"in","featured_image":"0","ignore_sticky_posts":"1","author_ids":"","disable_duplicate":"0","ad-active":0,"paginate":"more_btn","pagination-show-label":"1","columns":1,"listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"1","share":"0","comment":"1","review":"0"}},"override-listing-settings":"0","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"bs_post_listing","view":"Publisher_Thumbnail_Listing_1_Shortcode","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"more_btn","pagination-show-label":"1","override-listing-settings":"0","listing-settings":{"thumbnail-type":"featured-image","title-limit":"60","subtitle":"0","subtitle-limit":"0","subtitle-location":"before-meta","show-ranking":"0","meta":{"show":"1","author":"0","date":"1","date-format":"standard","view":"1","share":"0","comment":"1","review":"0"}},"columns":1,"ad-active":false,"_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"1346935","data":{"vars":{"post-ranking-offset":5}}}';</script> <a rel="next" class="btn-bs-pagination" data-id="1762097763" title="Load More Posts">
<span class="loading" style="display: none;">
<i class="fa fa-refresh fa-spin fa-fw"></i>
</span>
<span class="loading" style="display: none;">
Loading ... </span>
<span class="loaded txt">
Load More Posts </span>
<span class="loaded icon">
<i class="fa fa-angle-down" aria-hidden="true"></i>
</span>
<span class="no-more" style="display: none;">
No More Posts
</span>
</a>
</div></div></div><div id="bs-subscribe-newsletter-2" class=" h-ni w-t primary-sidebar-widget widget widget_bs-subscribe-newsletter"><div class="section-heading sh-t1 sh-s1"><span class="h-text">Sign up to get VIDEO alerts</span></div> <div class="bs-shortcode bs-subscribe-newsletter bs-feedburner-newsletter ">
<div class="subscribe-image">
<img src="https://nehandatv.com/wp-content/themes/publisher/images/other/email-illustration.png" alt="Sign up to get VIDEO alerts">
</div>
<div class="subscribe-message">
<p>Sign up to get VIDEO alerts</p>
</div>
<form method="post" action="//feedburner.google.com/fb/a/mailverify" class="bs-subscribe-feedburner clearfix" target="_blank">
<input type="hidden" value="nehandatv" name="uri" />
<input type="hidden" name="loc" value="en_US" />
<input type="text" id="feedburner-email" name="email" class="newsletter-email" placeholder="Enter your e-mail .." />
<button class="newsletter-subscribe" name="submit" type="submit">Subscribe</button>
</form>
</div>
</div></aside>
</div>
</div>
</div>
</main>
</div>
<footer id="site-footer" class="site-footer full-width">
<div class="footer-social-icons">
<div class="content-wrap">
<div class="container">
<div class="  better-studio-shortcode bsc-clearfix better-social-counter style-big-button colored in-5-col">
<ul class="social-list bsc-clearfix"><li class="social-item facebook"> <a href="https://www.facebook.com/NehandaTV" class="item-link" target="_blank"> <i class="item-icon bsfi-facebook"></i><span class="item-name"> Facebook</span> <span class="item-title-join"> Join us on Facebook</span> </a> </li> <li class="social-item twitter"> <a href="https://twitter.com/nehandatv" class="item-link" target="_blank"> <i class="item-icon bsfi-twitter"></i><span class="item-name"> Twitter</span> <span class="item-title-join"> Join us on Twitter</span> </a> </li> <li class="social-item youtube"> <a href="https://youtube.com/user/NehandaTV" class="item-link" target="_blank"> <i class="item-icon bsfi-youtube"></i><span class="item-name"> Youtube</span> <span class="item-title-join"> Join us on Youtube</span> </a> </li> <li class="social-item instagram"> <a href="https://instagram.com/nehandatv" class="item-link" target="_blank"> <i class="item-icon bsfi-instagram"></i><span class="item-name"> Instagram</span> <span class="item-title-join"> Join us on Instagram</span> </a> </li> </ul>
</div>
</div>
</div>
</div>
<div class="copy-footer">
<div class="content-wrap">
<div class="container">
<div class="row">
<div class="col-lg-12">
<div id="menu-footer" class="menu footer-menu-wrapper" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<nav class="footer-menu-container">
<ul id="footer-navigation" class="footer-menu menu clearfix">
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-12172"><a href="https://nehandatv.com/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-15822"><a href="https://nehandatv.com/contact-us-2/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-7934"><a href="https://nehandatv.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-38970"><a href="https://nehandatv.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22542"><a href="http://tellyafrica.com/">Telly Africa</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom better-anim-fade menu-item-22541"><a href="http://nehandaradio.com/">Nehanda Radio</a></li>
</ul>
</nav>
</div>
</div>
</div>
<div class="row footer-copy-row">
<div class="copy-1 col-lg-6 col-md-6 col-sm-6 col-xs-12">
© 2020 - Nehanda TV. All Rights Reserved. </div>
<div class="copy-2 col-lg-6 col-md-6 col-sm-6 col-xs-12">
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
<span class="back-top"><i class="fa fa-arrow-up"></i></span>
<script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({flush: true});</script><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-49233918-3', 'auto');
  ga('send', 'pageview');

</script><script>
var bs_pagination_loc = {"loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>"};
</script>
<script>
var publisher_theme_global_loc = {"page":{"boxed":"full-width"},"header":{"style":"style-2","boxed":"full-width"},"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>","translations":{"tabs_all":"All","tabs_more":"More","lightbox_expand":"Expand the image","lightbox_close":"Close"},"lightbox":{"not_classes":""},"main_menu":{"more_menu":"enable"},"top_menu":{"more_menu":"enable"},"skyscraper":{"sticky_gap":30,"sticky":true,"position":"after-header"},"share":{"more":false},"refresh_googletagads":"1","notification":{"subscribe_msg":"By clicking the subscribe button you will never miss the new articles!","subscribed_msg":"You're subscribed to notifications","subscribe_btn":"Subscribe","subscribed_btn":"Unsubscribe"}};
var publisher_theme_ajax_search_loc = {"ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","previewMarkup":"<div class=\"ajax-search-results-wrapper ajax-search-no-product ajax-search-fullwidth\">\n\t<div class=\"ajax-search-results\">\n\t\t<div class=\"ajax-ajax-posts-list\">\n\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t<span>Posts<\/span>\n\t\t\t<\/div>\n\t\t\t<div class=\"posts-lists\" data-section-name=\"posts\"><\/div>\n\t\t<\/div>\n\t\t<div class=\"ajax-taxonomy-list\">\n\t\t\t<div class=\"ajax-categories-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Categories<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"categories\"><\/div>\n\t\t\t<\/div>\n\t\t\t<div class=\"ajax-tags-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Tags<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"tags\"><\/div>\n\t\t\t<\/div>\n\t\t<\/div>\n\t<\/div>\n<\/div>","full_width":"1"};
</script>
<div class="rh-cover noscroll gr-8 no-login-icon no-top-nav">
<span class="rh-close"></span>
<div class="rh-panel rh-pm">
<div class="rh-p-h">
</div>
<div class="rh-p-b">
<div class="rh-c-m clearfix"><ul id="resp-navigation" class="resp-menu menu clearfix"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-2 better-anim-fade menu-item-1551"><a href="https://nehandatv.com/category/bizarre/">Bizarre</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-4 better-anim-fade menu-item-1552"><a href="https://nehandatv.com/category/comedy/">Comedy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-5 better-anim-fade menu-item-1563"><a href="https://nehandatv.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-840 better-anim-fade menu-item-10925"><a href="https://nehandatv.com/category/dance/">Dance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-8 better-anim-fade menu-item-1557"><a href="https://nehandatv.com/category/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-10 better-anim-fade menu-item-1554"><a href="https://nehandatv.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-11 better-anim-fade menu-item-1555"><a href="https://nehandatv.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-term-13 better-anim-fade menu-item-1556"><a href="https://nehandatv.com/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-15 better-anim-fade menu-item-10924"><a href="https://nehandatv.com/category/sports/">Sports</a></li>
</ul></div>
<form role="search" method="get" class="search-form" action="https://nehandatv.com">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" autocomplete="off">
<input type="submit" class="search-submit" value="">
</form>
</div>
</div>
</div>
<script type='text/javascript'>
/* <![CDATA[ */
var better_post_views_vars = {"admin_ajax_url":"https:\/\/nehandatv.com\/wp-admin\/admin-ajax.php","post_id":"52762"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nehandatv.com/wp-content/plugins/better-post-views/js/better-post-views.min.js?ver=1.5.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"nehandatv"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nehandatv.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"52762 https:\/\/nehandatv.com\/?p=52762","disqusShortname":"nehandatv","disqusTitle":"Full address by Nelson Chamisa: Zimbabwe 40th Independence Day","disqusUrl":"https:\/\/nehandatv.com\/2020\/04\/18\/full-address-by-nelson-chamisa-zimbabwe-40th-independence-day\/","postId":"52762"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nehandatv.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://nehandatv.com/wp-includes/js/comment-reply.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://nehandatv.com/wp-includes/js/wp-embed.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.4' async='async'></script>
<script type='text/javascript' src='https://nehandatv.com/wp-content/plugins/better-adsmanager/js/advertising.min.js?ver=1.19.2'></script>
<script type='text/javascript' async="async" src='https://nehandatv.com/wp-content/bs-booster-cache/c128a510bd0ac07e6f39bd364e1e247e.js?ver=5.4'></script>
<script>
var qfj=function(a){"use strict";return{init:function(){0==qfj.ads_state()&&qfj.blocked_ads_fallback()},ads_state:function(){return void 0!==window.better_ads_adblock},blocked_ads_fallback:function(){var e=[];a(".qfj-container").each(function(){if("image"==a(this).data("type"))return 0;e.push({element_id:a(this).attr("id"),ad_id:a(this).data("adid")})}),e.length<1||jQuery.ajax({url:'https://nehandatv.com/wp-admin/admin-ajax.php',type:"POST",data:{action:"better_ads_manager_blocked_fallback",ads:e},success:function(e){var t=JSON.parse(e);a.each(t.ads,function(e,t){a("#"+t.element_id).html(t.code)})}})}}}(jQuery);jQuery(document).ready(function(){qfj.init()});

</script>

<script>
 var disqus_shortname = 'nehandatv';
            (function () {
                var s = document.createElement('script'); s.async = true;
                s.type = 'text/javascript';
                s.src = '//' + disqus_shortname + '.disqus.com/count.js';
                (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
            }());
		//<script>

		(function(){
		var disqus_shortname = 'nehandatv';


		function beforeLoad(e,$wrapper, $this) {

             var $prevEl = jQuery('#disqus_thread');

             if($prevEl.length === 0) {
                 return;
             }

            $prevEl.removeAttr('id');

            $prevEl.addClass('disqus_thread_prev');
		}

		function appendDisqusScript(e,$wrapper, res) {

		if( typeof DISQUS === 'object' && DISQUS.reset ) {

        var info = res && res.info ? res.info : {};


		jQuery(".disqus_thread_prev").each(function(){

		    var $prevEl = jQuery(this),
		        $respond = $prevEl.closest('.comments-template'),
		     $link = $respond.parent().find('.ajaxified-comments-container');

            $link.show();
			$link.children().show();

			$respond.remove();

		});

		DISQUS.reset({
		reload: true,
		config: function () {
		this.page.identifier = info.post_id;
		this.page.url = info.permalink;
		this.page.title = info.title;
		}
		});



		} else {

		var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
		dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
		}

		};

		        appendDisqusScript();
		
		})();
		

</script>

</body>
</html>
